How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15482
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

Have 2008 chevy 2500 Express. Engine is 4.8. Driving down

Customer Question

Have 2008 chevy 2500 Express. Engine is 4.8. Driving down highway and quit running. Changed the fuel pump and relay still no power to fuel pump. Do have spark as it will run run on starting fluid. Also fuse is good.
Submitted: 28 days ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 28 days ago.

Hi, My name is ***** ***** for the delay.
I will do my best to assist you.

Expert:  Tim's Auto Repair replied 28 days ago.

does the fuelpump come on for the first 2 seconds when you first turn on the ignition?

Customer: replied 28 days ago.
No
Expert:  Tim's Auto Repair replied 28 days ago.

ok

does the relay click when you firsturn on the ignition?

Customer: replied 28 days ago.
plus I replaced the relay
Expert:  Tim's Auto Repair replied 28 days ago.

so,,the relay does click,,yet the pump doesnt come on for the first two seconds?

Customer: replied 28 days ago.
Correct
Expert:  Tim's Auto Repair replied 28 days ago.

ok,,have you checked the power wire at the pump,,if should have power on the big gray when the relay clicks on..

from the way you explain,it sounds as if you have a problem in the wire harness..

pleasse stand by

Expert:  Tim's Auto Repair replied 28 days ago.

if the relay is clicking on,,the van itself is doing its job,,so it is loosing power from the relay to the pump or the ground.

Expert:  Tim's Auto Repair replied 28 days ago.

providing the pump is good.

so you need to check for power at the pump,,it should power up for 2 seconds when you first turn on the ignition

Expert:  Tim's Auto Repair replied 28 days ago.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there.please copy and paste the link below to your main browser[INTERNET EXPLORER ,Chrome or Firefox.]

.

https://www.dropbox.com/s/8y5fj8ysnya6e1s/1110-van-Fuel%20System%20Description.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/8y5fj8ysnya6e1s/1110-van-Fuel%20System%20Description.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 28 days ago.
Also removed the ground and re-installed. Check for power at pump. No power at connector with gray wire
Expert:  Tim's Auto Repair replied 28 days ago.

ok

it will only have power for the first two seconds and will always have power when the engine is turning

Expert:  Tim's Auto Repair replied 28 days ago.

if you have no power at all on the gray,,then,your problem is from the relay to the pump..it is a wire problem,,you will need to test to find it

thanks

Customer: replied 28 days ago.
Where should I start testing? Also what is the box in front of the fuel tank and the round cylinder located with it? I noticed a wire connector and does these items have any reference to the power at the fuel pump
Expert:  Tim's Auto Repair replied 28 days ago.

i would think you are talking about the evap canister,,it has nothing to do with the pump power

Expert:  Tim's Auto Repair replied 28 days ago.

the power to the pump comes direct from the fuel pump relay

Expert:  Tim's Auto Repair replied 28 days ago.

you need to start check the wire harness at the pump and work your way back to the relay till you find the problem to why you are loosing power

Expert:  Tim's Auto Repair replied 28 days ago.

use the wire diagram i sent you so you can see how it works

thanks