How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Upon starting the engine the electrical power to the HVAC

Customer Question

Upon starting the engine the electrical power to the HVAC and overhead trip display is delayed for up to 10 minutes sometimes, but the delay time is inconsistent.
JA: Will the headlights turn on? Is the battery fully charged?
Customer: Yes, everything works perfectly immediately after starting engine except the AC and overhead display. There seems to be no electrical power to these items until some time passes(30 seconds to 10 or 15 minutes) then they power up and function normally until the ignition switch is cycled off again.
JA: What is the make/model of your car?
Customer: 2002 Monte Carlo SS 3.8
JA: Are you fixing your Monte Carlo yourself? What have you tried so far?
Customer: General electrical connection wiggle tests.
JA: Anything else you want the mechanic to know before I connect you?
Customer: no
Submitted: 1 month ago.
Category: Chevy
Expert:  Pete replied 1 month ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Has anything after market been installed at all that may have caused this issue here that you know of?

Has anything been checked or tested for this issue here at all?

Let me know so we can continue,thanks Pete

Customer: replied 27 days ago.
Sorry for the delay, been out of town. The car is 100% original, nothing aftermarket. When the issue originally started it was more pronounced when the humidity was high (after rain, etc.) lately it has been consistently random regardless of humidity levels. The problem first occurred over a year ago and I have just been dealing with it. I can't tell if it is a problem with the ignition switch or BCM or ?. Once the AC and trip display powers up after starting the car it NEVER fails during continued operation. Only after turning ignition off will the delayed turn on reoccur.
Expert:  Pete replied 27 days ago.

No problem

Are you able to remove the heater/ac control unit and have a test light or multi meter to do some electrical testing at all?

Is it acting up now at all?

Customer: replied 20 days ago.
as soon as I get back in town I can get it in my shop and get it opened up for electrical diagnostics on the control unit.