How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Chevy
Satisfied Customers: 24668
Experience:  14 years GM dealer Technician.
14928985
Type Your Chevy Question Here...
Pete is online now
A new question is answered every 9 seconds

I have 3 Chevrolet trucks doing the exact same thing. 1)

Customer Question

I have 3 Chevrolet trucks doing the exact same thing. 1) 1997 Chevrolet 1500 5.7l. 2) 1997 Chervrolet S-10 4.3L and 3) 2001 S-10 4.3l. All of these same problem. Sometime will start fine and sometimes will not all when will not start back fires and spits and has reverse rotation on motor, now all following parts replaced on all. fuel pump, dist cap rotor, plugs, wires, crank sensor, cam sensor. There are no codes on the trucks. I know this has to be a common problem. Any ideas?
Submitted: 1 month ago.
Category: Chevy
Expert:  Pete replied 1 month ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

I have seen as one of the bigger issues with the engine coolant temp sensor sending a false signal telling the engine computer that it is warm when in fact it is cold.If you have not had this checked this should be done to see if the engine coolant temp sensors are sending a false signal needing replaced.If these are or were checked and found o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 month ago.
ok new one installed did not work
Expert:  Pete replied 1 month ago.

Were the fuel pressure regulators on the injector units checked to see if any are leaking down at all into the intake as the engine is off after warmed up or when cold?

Customer: replied 22 days ago.
Sorry been sick. Checking now
Expert:  Pete replied 22 days ago.

No problem.Let me know what you come up with here.

Thanks Pete

Related Chevy Questions