How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Auto Mech / Electronics
Category: Chevy
Satisfied Customers: 20525
Experience:  Chevrolet Cert., Heavy Line Mech, Race Shop Owner, Mobile Electronics.
1609972
Type Your Chevy Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Then radio works and the speakers but it sounds awful and i

Customer Question

then radio works and the speakers but it sounds awful and i think the amp is bad but i can't find out where the amp is located. i bought a new radio and its doing the same thing so i know it has to be the amp. where is this located at.
JA: Have you checked the fuse?
Customer: yes i checked the fuse under the hood its a 30 amp
JA: What is the model/year of your Chevy?
Customer: 2008 silverado 4 door 1500
JA: Are you fixing your Silverado yourself? What have you tried so far?
Customer: yes i am i have checked the fuse replace the radio
JA: Anything else you want the mechanic to know before I connect you?
Customer: no i am just trying to find the location of the amp
Submitted: 1 month ago.
Category: Chevy
Expert:  EricFromCT replied 1 month ago.

Hi. The amplifier for the radio is under the center console. Once removed there is a bracket to remove then the amplifier can be removed.

Customer: replied 1 month ago.
it wasn't there it's not in the center console
Expert:  EricFromCT replied 1 month ago.

It is not in the center console. It is under it.

Customer: replied 1 month ago.
no its not there either I don't even see wires going near my console
Expert:  EricFromCT replied 1 month ago.

Do you have the console removed?

Customer: replied 1 month ago.
I do. there is carpet there and the floor
Expert:  EricFromCT replied 1 month ago.

perhaps your truck is not equipped with the amplifier. Because I know that is where it is. I have the GM service manual that shows it there.

Customer: replied 1 month ago.
ok but when the radio is on it works and I get music coming out of the speakers but there is no bass or treble it sounds really high pitched and it sounds sooo bad.
Expert:  EricFromCT replied 1 month ago.

How long have you owned this truck? Did this just happen all of a sudden?

Customer: replied 1 month ago.
we have it 3 years and it just and it just started a month ago I bought a new radio same kind and it does the same thing
Expert:  EricFromCT replied 1 month ago.

I am not really sure. All my expertise and info says the amp is under the console. I will opt-out and perhaps another expert will have some better insight on this problem. Hold tight and another expert should be along. THanks.

Customer: replied 1 month ago.
thanks my friend
Expert:  Don 'Mo Lurch' replied 1 month ago.

Greetings...... “Hi, I’m Don (akaCustomer and I look forward to helping you!”
IF this is the Factory Radio (not aftermarket" there is only 2 places GM installed the Amplifier:
Under Center Console....see attachment
Or under the Passenger side Dash, left of the Glove Box
Your Truck may not have come with Factory Amplifier, so the No Bass & bad sounds could be a speaker or 2 or even more
Factory Speakers do not stand up to use for very long & it only takes one bad speaker to cause sound issues, as the Factory uses "floating grounds" which a short affects ALL Speakers.
If there is NO Amplifier, I would suggest removing the Front Door Panels & have a look at the Front Speakers for cracks, tears, or moisture intrusion
I have been GM Radio Warranty for over 20 years.
Let me know if you need further

.

Customer: replied 1 month ago.
my console doesn't look like that I have a two level one the top part is like a glove box with cup holders and the bottom one has a lock on it and is flush with the seats.
Expert:  Don 'Mo Lurch' replied 1 month ago.

I understand.......either way, the Amp is only in those 2 areas that I posted

Customer: replied 1 month ago.
ok my friend is dark now I will look at this tomorrow. thanks for your help and have a great night. I will check it all tomorrow and get back with you all. thanks again
Expert:  Don 'Mo Lurch' replied 1 month ago.

thank you

Let me know if you need further.........

Customer: replied 1 month ago.
thank you!!!
Expert:  Don 'Mo Lurch' replied 1 month ago.

.

Expert:  Don 'Mo Lurch' replied 1 month ago.

.

did you need more information?
please respond or rate my answer

thank you

Expert:  Don 'Mo Lurch' replied 1 month ago.

Did you have any other questions?
I see you have viewed my reply but have not selected a rating.
Rating does not incur any additional costs, it simply allows me to be compensated for my time here.
It also does not close the question, you can follow up at any time.
Thank you.

Expert:  Don 'Mo Lurch' replied 1 month ago.

is there still a problem?

.

did you need more information?
please respond or rate my answer

thank you