How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

2008 Chevrolet Express Cargo Van. No rear or left front turn

Customer Question

2008 Chevrolet Express Cargo Van. No rear or left front turn signals. No brake lights, although the third brake light above the rear doors does come on when the brakes are applied. Right front turn signal works but flashes fast (this is the only turn signal that works) Four way flashers only flashes the right front and it flashes at normal pace, the flasher sound is there and the green arrows on the dash blink but thats it. Headlights and running lights all work as they should. I bought this van cheap because of this problem.
Submitted: 6 months ago.
Category: Chevy
Expert:  david craig replied 6 months ago.

Hi Im David. allow me a few to look up information on your vehicle. thanks.

Customer: replied 6 months ago.
okay
Expert:  david craig replied 6 months ago.

do you have a multi meter?

Expert:  david craig replied 6 months ago.

have you checked all of the fuses in the engine compartment that are related to turnsignals/brake lights ?

Customer: replied 6 months ago.
I have a multimeter. I have checked most of the fuses but I still have to check the rest. At this point there were 2 blown fuses but nothing changed when I put new fuses in. I will check the rest of them now. One of the BCM Fuses was blown and when I put another one in it blew immediately. I noticed a two wire plug hanging from under the steering column with a paper clip crossing the pins, I removed the paper clip and then the BCM fuse did not blow again. I looked around and this plug was to the brake light switch on the brake pedal. I plugged it back in but still no brake lights and no further Blown BCM fuse. This Van was at a repair shop and they couldnt fix it so that is how I got it. It runs great and has no other problems just the lights.
Expert:  david craig replied 6 months ago.

sounds like some shoddy work to me. check the rest of the fuses first then we can at least know there are all good fuses we are working with.

Customer: replied 6 months ago.
I will do it now.
Customer: replied 6 months ago.
No other blown fuses.
Expert:  david craig replied 6 months ago.

ok, first things first. they were trying to get brake lights by jumpering that connector, which of course blew the bcm fuse. so, withe the connector put back on, press the brake pedal and check for power back at the sockets for the brake light bulbs. you're going to need 2 people for this. this is to comfirm whether power is getin there or not and then we can check to make sure the grounds are good for the brake lights

Customer: replied 6 months ago.
Okay, I will do that now.
Customer: replied 6 months ago.
I disconnected the 4 wire connector that goes to the tail light assembly on the right side. I have no power to any of the 4 pins with the brake pedal applied. I can see however that the third brake light above the cargo doors does light up. I made sure my meter was working properly by turning on the parking lights and I then had 12V at that one pin that operates the parking light bulb,
Expert:  david craig replied 6 months ago.

the third brake light is on a totally different circuit

Customer: replied 6 months ago.
Okay
Expert:  david craig replied 6 months ago.

ok, check the connectors for a good ground. let me see if i can find out what position the ground wire is in the connector.

Customer: replied 6 months ago.
There is a ground wire that comes out of the harness right next to the connector on both sides in the rear. I used that ground wire for my test and it worked fine. Of course i have no way of knowing if this is the same ground wire that the lights use.
Expert:  david craig replied 6 months ago.

it is it should go into the connector if you follow it.

Customer: replied 6 months ago.
whats the next step? Im running out of time, I have to be at the dentist in an hour.
Expert:  david craig replied 6 months ago.

we're going to need more than an hour for this my friend. the previous owners got some wiring messed up somewhere

Expert:  david craig replied 6 months ago.

youre going to need to test the brake switch to see if its opening ans closing. back probe the connector and select ohms and operate the switch

Customer: replied 6 months ago.
Shouldnt we see if there is power coming to the switch? It has four wires at the connector. Which one should have power?
Expert:  david craig replied 6 months ago.

let me get a drawing.

Expert:  david craig replied 6 months ago.

check for power at the red/white wire

Customer: replied 6 months ago.
There is no red/white wire. We have: solid purple, orange/white,solid pink, green/white
Expert:  david craig replied 6 months ago.

then my manuals wrong...not the first time.

Expert:  david craig replied 6 months ago.

probe the connector for 12 volts.

Customer: replied 6 months ago.
Okay, im out of time here. I asked my question at 8:05 and now its been over two hours and I have tested one wire for power. If this is out of your area of expertise thats no problem just let me know. Otherwise can we pick this back up around noon 12:00 Eastern time?
Expert:  david craig replied 6 months ago.

nothin is out of my expertise and i am helping 4 different people right now. i will be opting out of this question. good day.

Customer: replied 6 months ago.
Well if you didnt have time for me then you should have said something in the beginning. My time is just as valuable as yours is. Your troubleshooting skills are lacking.
Customer: replied 6 months ago.
I dont have 24 hours to diagnosis a problem. !!!!!!!!!
Customer: replied 6 months ago.
It's my fault, I should have asked for someone else when I realized you didnt know what you were doing or didnt have the resources available to help me.
Expert:  david craig replied 6 months ago.

please quit responding to me as it keeps giving me back the question. as for your insults, they are not appreciated. again, if you respond back it will send it back to me and not allow another tech to be able to hello you. good day to you sir.