How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I had major repairs done on my 07 Equinox recently including

Customer Question

I had major repairs done on my 07 Equinox recently including a new head gasket, radiator, temp sensor, and thermosat. It was running fine except the temp gauge suddenly quit causing the fans to run anytime I was driving it. Then one day it wouldn't start so I ended up with a new battery, new starter, new starter relay. Afterwards the temp gauge worked briefly then dropped out again. I tried pulling the ECM fuse to reset the computer and now it won't start at all again. I did not disconnect the negative battery cable before pulling the fuse. The fuse itself is still fine. What else should I check before I assume there is a larger problem?
Submitted: 6 months ago.
Category: Chevy
Expert:  Tool Hut replied 6 months ago.

Hi, My Name is ***** ***** for posting your question to just answer. I am a independent contractor for just answer. ASE Certified Master Auto Technician with 20 years experience. I am confident we can resolve your problem together.Please remember I don't know your skill level. I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies to get to a satisfactory resolution.There will probably be some equipment needed for a proper diagnosis. If you are not comfortable with this or do not have any test equipment please let me know ASAP. I also give you all of the information you may need in good faith expecting a positive rating. I am not compensated for my time until you leave a positive rating. Your rating should be based on the service you received.

Do you have a solid security light on dash?

Customer: replied 6 months ago.
There is no security light on. I have little experience but do have access to a multimeter and also someone who knows how to work it. I basically want to know where to start. I tried unhooking the negative battery cable for 10 minutes and it didn't work. I rechecked the ecm fuse to make sure I didn't blow it when I put it back in.
Expert:  Tool Hut replied 6 months ago.

I would not suggest removing the fuse again. The coolant gauge is likely a bad coolant temperature sensor. They are cheap and prone to failure. SO now on to the no start situation.

Does the starter crank the engine?

Customer: replied 6 months ago.
The dash lights come on and the starter clicks but no crank. I had someone check the starter and it is working and swapped out the starter relay with another relay and no start. The message board on the dash is just saying "service stabilitrak" and "service vehicle". no check engine light though it was on before I pulled that fuse. I am wondering if I shorted out a relay or a ground. Hopefully I didn't cause a problem to the actual computer.
Expert:  Tool Hut replied 6 months ago.

If the starter clicks, it is a bad starter. If you have a test light I can direct you to verify that. Do you have a scanner that you can read chassis data with? I would like you to read the chassis codes.