How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask kalamykid Your Own Question
kalamykid, Shop Owner/ Tech
Category: Chevy
Satisfied Customers: 3645
Type Your Chevy Question Here...
kalamykid is online now
A new question is answered every 9 seconds

Good bye, I just want to read the forum, 02 1500 hd, My

Customer Question

Good bye
JA: OK. To minimize me, please click the down arrow at the top right corner of this box.
Customer: I just want to read the forum
JA: What is the model/year of your Chevy?
Customer: 02 1500 hd
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: My instrument cluster went out so I went and bought an instrument cluster from a parts store and put it in my pickup and now it has set off my security pass dealer something I don't know but it has shut off my fuel pump. So now I need to figure out I went back to the mechanic or should I say parts store and got my original heart back and was told I could put that back in and everything would run but instead it's still doing the same deal so I have to reset my pass code I guess or something
JA: Do you have a scan tool to read the codes?
Customer: No and it's stuck in my driveway this point in time it ran yesterday I took the instrument cluster out it turned over and ran even with the dash out I turned it off left alone put the new one in this morning and that's when nothing it turns over wants to start but then the fuel pump not getting fuel
JA: Anything else you want the mechanic to know before I connect you?
Customer: Nope
Submitted: 21 days ago.
Category: Chevy
Expert:  kalamykid replied 21 days ago.

Did you write down the mileage before you pulled out the old instrument cluster?

Customer: replied 21 days ago.
Before my cluster went out my mileage yes I do know but it was out for about a day and I couldn't see anything I had no speedometer had no RPM and all my other gauges were stuck
Expert:  kalamykid replied 21 days ago.

You will have to have the pcm "computer" reflashed to get the security system to reset. The pcm did not recognize the new cluster so it went into theft mode. You will need to install the new cluster, take the pcm to have it reflashed, install the reflashed pcm and then do a 30 minute relearn on the security system. I will post the relearn for you so you know what to do. If you want to use your old one till you have the pcm reflashed, do the 30 minute relearn and it will start again.

Customer: replied 21 days ago.
Yeah I went to try that earlier and I don't have a security light on my old
Customer: replied 21 days ago.
Or new Dash cluster
Expert:  kalamykid replied 21 days ago.

What size engine do you have in your truck please?

Customer: replied 21 days ago.
Expert:  kalamykid replied 21 days ago.

You have to try to start the engine and then let the switch go into the run position for the security light to light up, or flash. Can you try this with the old cluster in the truck and tell me if the security light comes on at all please?

Customer: replied 21 days ago.
I do not see anything but my check engine light on that old cluster of gauges
Expert:  kalamykid replied 21 days ago.

Can you put the new cluster in and see if the security light will come on after you bump the starter and leave the switch in the run position please?

Customer: replied 21 days ago.
No I have no security light or security sign anything anywhere I don't know if it's supposed to be in that little window that says you know change oil or seat belt or any of that stuff but I don't see anything popping up even with the new cluster. Now a quick note this thing ran yesterday even after I took out the original cluster gauges I started it and made a joke well hell I guess I could run it even with the dash gauges not there. And then today I got this new cluster plugged it in and mediately and tried to start it and that's when it did this it started for a quick second and then it was nothing now it's not getting fuel at fuel pump at all
Expert:  kalamykid replied 21 days ago.

Have you checked all the fuses with the ignition switch on with a test light to make sure you had power to both sides of ALL of the fuses?

Customer: replied 21 days ago.
No I guess that can be my first thing I check first thing in the morning it's now getting pretty late here I don't know where you're located but I sure appreciate you trying to help me this late
Expert:  kalamykid replied 21 days ago.

You are very welcome. I am in tennessee so it is 1:30 am here. I will be back on line around 11 am so if you need me I will be here.

Customer: replied 21 days ago.
Yeah it's getting late for you buddy well my name is***** and I live here in Coeur d'Alene Idaho so its almost 11 here. And thanks for the offer I will let you know what I find out in the morning
Expert:  kalamykid replied 21 days ago.

Hi Chris, I am Jamie and will chat with you tomorrow.

Customer: replied 20 days ago.
Good afternoon Jamie... I just checked my fuses with a test light everything checks out I am so confused and irritate on the stupid thing. I was wondering if my security light if that would light up in that little digital box up the left hand side that usually will Flash change oil or seat belts or other things I guess but I don't think I've ever seen a security light on it
Expert:  kalamykid replied 20 days ago.

I need to know what fuses did not have power to them, as well as what fuses only had power to one side with the ignition switch on please.