How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

A sensor (?) on a 1999 chevy tahoe 350 5.7L that is yellow

Customer Question

a sensor (?) on a 1999 chevy tahoe 350 5.7L that is yellow with green o-rings is unable to locate (under the hood)
JA: Which particular sensor are you asking about? And have any trouble codes been triggered?
Customer: No codes have been checked....
JA: Are you fixing your Tahoe yourself? What have you tried so far?
Customer: yes
JA: Anything else you want the mechanic to know before I connect you?
Customer: I cleaned the sensor once and it ran....next day it wouldn't start
Submitted: 3 months ago.
Category: Chevy
Expert:  kalamykid replied 3 months ago.

Please tell me more about your problem. I need to know more about the sensor you are trying to locate, what the truck has been doing as well as every thing you have done to this point please.

Customer: replied 3 months ago.
Truck won't start. Turns over tho. I cleaned a sensor (yellow with green o-rings) and truck started right up. Drove it for the day, the next morning truck would not start....can NOT locate the sensor again..... memory problems.
Expert:  kalamykid replied 3 months ago.

Are you talking about the idle air control valve? It would be gold or silver with a green oring and is mounted into the side of the throttle body.

Expert:  kalamykid replied 3 months ago.

Do you remember if it was on top of the engine or under the truck on the lower front of the engine?

Customer: replied 3 months ago.
It could have been gold and by the throttle body.....
Customer: replied 3 months ago.
it has a connector and pulls right out...it's not bolted or fastened to any engine part.
Expert:  kalamykid replied 3 months ago.

can you send me a couple of pics of the engine bay please?

Customer: replied 3 months ago.
pics to where...??
Expert:  kalamykid replied 3 months ago.

Do you have the pics? I can send you a link that will show you how to upload them.