How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Auto Mech / Electronics
Category: Chevy
Satisfied Customers: 20427
Experience:  Chevrolet Cert., Heavy Line Mech, Race Shop Owner, Mobile Electronics.
Type Your Chevy Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Speakers wont work after blower motor repair, 150 automatic,

Customer Question

Speakers wont work after blower motor repair
JA: How many miles are on the car? Is it an automatic or a manual transmission?
Customer: 150 automatic
JA: What is the model/year of your Chevy?
Customer: Taho 99
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Nothing
JA: Anything else you think the mechanic should know?
Customer: No
Submitted: 1 month ago.
Category: Chevy
Expert:  Don 'Mo Lurch' replied 1 month ago.

IF this is the Factory Radio, sounds like someone may have disconnected the Factory Amplifier, which is under the Passenger side Dash, near the Blower motor

Customer: replied 1 month ago.
Is it above the motor or where
Expert:  Don 'Mo Lurch' replied 1 month ago.

IF the Radio comes on & displays the Channels or plays a CD, check the AMP behind the Passenger Dash
Click Attachment below

Unless you have the Console & the AMP is sometimes there.........
IF you have the Console, then test the Fuse "13 located in the Inside Fuse Panel

Related Chevy Questions