How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Chevy
Satisfied Customers: 43909
Experience:  16 years of experience
Type Your Chevy Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 97 Tahoe LT 2 door 4wd. I have no tail lights when

Customer Question

I have a 97 Tahoe LT 2 door 4wd.
JA: What is the model of your '97 Chevy?
Customer: I have no tail lights when headlights are turned on, but the 3rd brake light comes on. If I turn the headlights off, and turn on flashers, the tail lights will flash (so will the license plate lights), but they are very dim. The turn signals seem to work ok with headlights off and no brake, but if I turn on headlights or step on brake, I get the fast flash. I also have no back up lights.
JA: Have you checked the bulbs? Have you checked the connection?
Customer: I've checked all of the fuses, the taillight assemblies, including circuit boards and bulbs are new. I replaced them for appearance, the old still worked. I put the old back on, same problem.
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: I'd like to fix it myself, if possible. I've cleaned the ground on the driver side rear and checked with meter; seems good. I recently replaced the multi function switch for a different reason - it was getting hard to actuate and becoming a nuisance when changing lanes. All worked great for two days. Drove through a bad rainstorm. Next day I had the fast blinking, and then all of this.
JA: Anything else you think the mechanic should know?
Customer: There is a Viper alarm system installed, but it seems to work normal.
Submitted: 2 months ago.
Category: Chevy
Expert:  Chris (aka-Moose) replied 1 month ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.working after noon till just after midnight.

  • Sorry no one has helped yet.
  • Yes, you have been charged already.
  • Yes, I am aware of the time you asked your question and time I am responding.
  • I will be online a couple more hours after this post.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
  • So far this looks to be a wire short or BCM issue. Can you do wire testing?
Expert:  Chris (aka-Moose) replied 1 month ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris