How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask mike switzer Your Own Question
mike switzer
mike switzer,
Category: Chevy
Satisfied Customers: 445
Experience:  lead diagnostic tech at Aamco
93239347
Type Your Chevy Question Here...
mike switzer is online now
A new question is answered every 9 seconds

2009 Chevy express van has no spark advance

Customer Question

2009 Chevy express van has no spark advance
Submitted: 3 months ago.
Category: Chevy
Customer: replied 3 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  mike switzer replied 3 months ago.

how did you check for a restricted exhaust?

Expert:  mike switzer replied 3 months ago.

also what are you long term fuel trims at idle?

Customer: replied 3 months ago.
I checked restricted exhaust with a vacuum gauge at idle 18" and 2500 rpm 20"+ did not note fuel what about ignition timing readings I'm getting from scan tooled I increase rpm timing regards ***** ***** advancing
Customer: replied 3 months ago.
Also I removed both oxygen sensors and drove no difference in power or vacuum readings
Customer: replied 3 months ago.
Did not note fuel trim
Expert:  mike switzer replied 3 months ago.

fuel trims will tell you if the maf sensor is working properly. the ignition timing is just what the showing what the computer is telling it to do. if it is retarding and not advancing it is sensing something in the fuel mixture that is telling it to due so. if your long term fuel trims are not 0 on both banks i would first try cleaning the maf or just replacing it.

Customer: replied 3 months ago.
i will check tomorrow if long term fuel trim is at zero this test should be done when and how idle underload? I also ran it with maf unplugged it set 4 codes but made no difference in power
Expert:  mike switzer replied 3 months ago.

these engines dont like an unplugged maf much at all. but just idle in park drive or anthing longterm should be 0.

Expert:  mike switzer replied 3 months ago.

also are you sure your transmission is not in limp mode? try if fuel trims are okay. unplugging the transmission harness and manually shifting through the gears while driving. it will be a bit harsher than normal but this will confirm whether or not you are in limp mode.

Customer: replied 3 months ago.
not in limp mode shifts through all 4 gears also tried pulling hill in manual low no difference
Expert:  mike switzer replied 3 months ago.

ok just wanted to verify

Customer: replied 3 months ago.
what should stall speed be I have 1300 rpm
Expert:  mike switzer replied 3 months ago.

that seems a bit low they are normally higher than that i cant remember the exact speed. let me see if i can find a good spec on that.

Customer: replied 3 months ago.
ok thanks
Expert:  mike switzer replied 3 months ago.

i cannot find a proper spec on the stall speed for the converter however i did find a tsb regarding the torque converter. also do you have any reduced engine power codes?

Expert:  mike switzer replied 3 months ago.

particularly p2135?

Customer: replied 3 months ago.
No codes other than perminant evaporative system code cant clear that code but computer recognizes codes when present and clears when problem is gone it set codes for o2 sensors when disconnected along with maf when disconnected and cleared and didn't return after reconnecting
Expert:  mike switzer replied 3 months ago.

ok

Customer: replied 3 months ago.
Long term fuel trim was not zero installed Genuine GM MAF sensor before both banks at 0 started vehicle it runs between - .8 and -4.7 both banks no improvement in regards ***** ***** What now?
Customer: replied 3 months ago.
Under no load or very light loads ignition advances now unlike yesterday also baro sensor pressure is fixed at 30hg
Customer: replied 3 months ago.
Testing of baro sensor 5 volt reference good ground feed back leg 4 volts no vacuum and gradually goes to zero volts at 25" of vacum
Expert:  mike switzer replied 3 months ago.

if everything else test out then it is going to be your throttle body assembly. that or the gas pedal assembly. 90% of the time it is the throttle body.

Customer: replied 3 months ago.
How can I test throttle body and gas pedal assembly?
Expert:  mike switzer replied 3 months ago.

give me a moment.

Customer: replied 3 months ago.
What did you mean by everything else checking out? Is there something else I need to check? What about the vacuum being fixed at 30" hg
Expert:  mike switzer replied 3 months ago.

ok while looking for testing procedures i found a tsb for the condition you are experiencing. the first step is to call the dealer and make sure that this vehicle has the proper ecm programming. if not it will need to be updated. and if it does the tsb states the throttle body will need to be replaced. i will attach the tsb give me a moment.

Expert:  mike switzer replied 3 months ago.

one is the tsb with diag instructions the other is a recal warranty extension.

Customer: replied 3 months ago.
Interesting reading but vehicle does not run rough or has it set any of the codes mentioned
Expert:  mike switzer replied 3 months ago.

well not advancing properly and lack of power to me is a type of rough running. and gm has had issues with ecm programming throughout many years so i would start with making sure the ecm is updated to the proper vesion. a local airbag service can usually do this. and they will come to you. i would atleast verify the version first.

Customer: replied 3 months ago.
Ok I will verify ECM programming tomorrow Thanks have Good night
Customer: replied 3 months ago.
No recalls or ECM calibration updates available FYI after replacing MAF I do now have ignition advance but before I spend $250 on throttle assembly and $50 on gas pedal I would like to confirm these do actually need replacing so can you give a testing procedure also I have not gotten a response from you regarding the vacuum on scan tool fixed at 30" in spite of MAP sensor back probing indicating sensor is responding vacuum fluctuactions see earlier message for test results Thanks
Customer: replied 3 months ago.
Still waiting for a response to last message
Customer: replied 3 months ago.
Are you planning on continuing to help me?
Customer: replied 3 months ago.
Are you planning on helping me solve my problem

Related Chevy Questions