How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Chevy
Satisfied Customers: 1573
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles A6 - Electrical / Electronic systems A7 Heating / Air Conditioning systems
45790705
Type Your Chevy Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

1999 suburban no start no fire coming out of coil.replaced

Customer Question

1999 suburban no start no fire coming out of coil.replaced coil ,coil modual, and crank sensor still no fire cranks ok. went dead while driving
Submitted: 3 months ago.
Category: Chevy
Customer: replied 3 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Chad Farhat replied 3 months ago.

Hi, I'm Chad ,Welcome To JustAnswer, I'm reviewing your question and I will be be posting a replay ASAP

Expert:  Chad Farhat replied 3 months ago.

have you checked the ground on the coil connector ?

this is sent from the pcm , if you changed the coil and module & crank sensor , that tells me power or ground or both are missing ?

can you check and let me know ?

the truck still spins over , just want start ,you have no fire , but you have fuel pressure correct ?

is there a red security light flashing or steady on when attempting to start on the dash ?

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 3 months ago.
ill be back in a little while volt meter broke need to go get new one has new fuel pump.no red light flashing
Expert:  Chad Farhat replied 3 months ago.

ok , get a test light if you have one

Customer: replied 3 months ago.
OK I'll use test light also I just plugged in code reader it shows 2codes p0339 and p0336 the crank sensor that I put in came out of my other suburban that I drive daily
Expert:  Chad Farhat replied 3 months ago.

THIS A CKP CIRCUIT ISSUE

Expert:  Chad Farhat replied 3 months ago.

We going to find power or ground is missing there ,

Expert:  Chad Farhat replied 3 months ago.

check crank sensor wiring

Expert:  Chad Farhat replied 3 months ago.

An intermittent may be caused by any of the following conditions: ^ A poor connection ^ Rubbed through wire insulation ^ A broken wire inside the insulation

Expert:  Chad Farhat replied 3 months ago.

there should be 2 20 amp fuses in the under hood fuse box, i m assuming you checked them ,if not please check

Customer: replied 3 months ago.
Checked all fuses with a visual but it quite suddenly like whe a fuse blows will check again but it just started raining hard am going to let it slow down
Expert:  Chad Farhat replied 3 months ago.

ok no problem , just reply back when ready, i m online till 12 pm tonight .

Chad

Customer: replied 3 months ago.
ok thanks for your help got it fixed there was a bare wire and the crank sensor was bad
Expert:  Chad Farhat replied 3 months ago.

well that is awesome , i m glad :)

Please let me know if you need anything else on it

Hope I was helpful to you

A Positive Rating is Much Appreciated

This Post Will Stay Open for You To Come back And Ask me Any Follow Up Question You May have.

Thank You

Chad Farhat
ASE Certified Technician