How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15816
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

2006 silverado 5.3L. Cranks slow like the battery is weak,

Customer Question

2006 silverado 5.3L. Cranks slow like the battery is weak, but I just installed a new battery and it currently has 12.5V. Sometimes when cranking, clock on radio resets to 12:00.
JA: How old is the battery? And have you tested it with a voltmeter?
Customer: just answered that.
JA: What is the model of your '06 Chevy?
Customer: silverado 1500 crew cab
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: yes. haven't tried anything yet.
JA: Anything else you think the mechanic should know?
Customer: Can't think of anything else. Just seems like a weak battery, but isn't.
Submitted: 9 months ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 9 months ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you.

Expert:  Tim's Auto Repair replied 9 months ago.

sense the clock does restet,,this tells me it is loosing connection with the battery when under load

Customer: replied 9 months ago.
what does this mean?
Expert:  Tim's Auto Repair replied 9 months ago.

sorry i lost you for a moment

Expert:  Tim's Auto Repair replied 9 months ago.

this to me means that you have a bad connection from the battery ..

you need to make sure that the battery cables are tight and clean at all 4 points

Expert:  Tim's Auto Repair replied 9 months ago.

the battery+ and - the starter+ and the engine -

Expert:  Tim's Auto Repair replied 9 months ago.

i would think ,from the way you explain,that your problem here is the battery cables

Expert:  Tim's Auto Repair replied 9 months ago.

if.the cables are not the problem,,then you may have a bearing bad in the starter motor,thus causing the starter to drag and making it pull way too many amps,,in this case the starter will need to be replaced

Expert:  Tim's Auto Repair replied 9 months ago.

thanks

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feedback ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help.