How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Chevy
Satisfied Customers: 43878
Experience:  16 years of experience
Type Your Chevy Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

Well was driving down the road about 30mph and a bunch of

Customer Question

Well was driving down the road about 30mph and a bunch of lights came on the instrument panel and then it just died. Engine will crank but no spark, no fuel condition exists. Any ideas?
JA: Just to clarify, what are the exact lights you're talking about?
Customer: It happened fast so couldnt catch it all but check engine was one of them.
JA: What is the model/year of your Chevy?
Customer: 98 chevy 1500 v6
JA: What year is your Oldsmobile?
Customer: pickup
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: the other odd thing is it wont see my code reader and no instrument lights come on in the run position
JA: Anything else you think the mechanic should know?
Customer: yes fix it myself. all fuses good. fuel pump relay changed.
Submitted: 2 months ago.
Category: Chevy
Expert:  Chris (aka-Moose) replied 2 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.working after noon till just after midnight.

  • Sorry no one has helped yet.
  • Yes, you have been charged already.
  • Yes, I am aware of the time you asked your question and time I am responding.
  • I will be online a couple more hours after this post.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help
Customer: replied 2 months ago.
no one has helped me
Expert:  Chris (aka-Moose) replied 2 months ago.

I need to confirm you did check and verify there is no spark and no fuel pressure, your not just assuming that is the cause?

Was the check engine light on prior to this?

Were there running issues prior?

Customer: replied 2 months ago.
confirmed no spark / no fuel. Check engine was on before for a 02 sensor. No running issues prior.
Expert:  Chris (aka-Moose) replied 2 months ago.

Thanks, ***** ***** the diagram we are going to be using for both issues.

Lets go after no fuel pressure first.

  1. At the removed fuel pump relay are you getting power and ground on the 2 coil side pins with the key on?
  2. Are you getting battery voltage on one of the switch side pins with the key on?

This is my 1st answer, but does not have to be my only answer. You the website and myself expect you to have a great experience with my help. Please let me know if you are pleased by selecting a star rating above or by replying and saying your pleased. Not rating or rating 1-2 stars does not benefit you nor me in any way. Follow up and reply as often and when needed, there is no extra charge to do so.

Thanks Moose.

Expert:  Chris (aka-Moose) replied 2 months ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris