How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Roy Your Own Question
Roy
Roy, import/domestic specialest
Category: Chevy
Satisfied Customers: 5304
Experience:  ASE master tech for 40 years
3506196
Type Your Chevy Question Here...
Roy is online now
A new question is answered every 9 seconds

2003 impala............have had right wheel bearing replaced

Customer Question

2003 impala............have had right wheel bearing replaced 3 times due to a C1226 code.............not solving the problem
JA: Just to clarify, what's the exact code? And have you tried to reset it?
Customer: c1226 how do you reset it
JA: Are you fixing your Impala yourself? What have you tried so far?
Customer: no had fixed at local shop.......the first wheel bearing was bad.......the grease was dried up............but after it being fixed had the same problem over again...........Service traction system, trac off and abs light all come on and sometimes when braking it makes a noise as if the traction system was activated
JA: Anything else you want the mechanic to know before I connect you?
Customer: the mechanic who fixed the car said he checked the wiring on both sides no frays or anything he could see
Submitted: 8 months ago.
Category: Chevy
Expert:  Roy replied 8 months ago.

good afternoon my name is ***** ***** I will assist

when they said they checked the wiring, did they uncover the harness and inspect at the lower control arms??? very common for the wires to break at that area,

once the abs system is repaired, it will clear itself and the trac light will also go out

Roy

Customer: replied 8 months ago.
to be honest I really don't know I thought he said he checked both sides on the front from the abs commuter to the wheels and found no problems...........also when I go to accelerate sometimes.....well a lot of the times the Traction Active light comes on.............so far the only code that has shown up has been c1226 saying right speed wheel sensor irractic possible bad wheel bearing but that's been changed three times now
Expert:  Roy replied 8 months ago.

I understand but the chances of having a 4 th bearing are really slim. it sounds like they missed the original failure.

Roy

Expert:  Roy replied 8 months ago.

Payment for this service failed, please do not fulfill yet. We will attempt to reach this customer to fix the situation

this is the message I got

once you resolve that, we can chat

Roy

Customer: replied 8 months ago.
Ive updated this information and there is no problem with this card
Expert:  Roy replied 8 months ago.

I have no control over money. I get a very small portion you are charged by the site. I will forward to customer service

Roy

Expert:  Roy replied 8 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy

Expert:  Roy replied 8 months ago.

please dont forget to rate me as it is the only way I get paid for my efforts

Roy