How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Z. Your Own Question
Ron Z.
Ron Z., - Chevy Tech -
Category: Chevy
Satisfied Customers: 18568
Experience:  18+yrs experience. State Inspector and Chevy Diagnostics
18617752
Type Your Chevy Question Here...
Ron Z. is online now
A new question is answered every 9 seconds

My 2004 Tahoe Z71 fan motor does not work on settings 1 & 2.

Customer Question

My 2004 Tahoe Z71 fan motor does not work on settings 1 & 2. My local Chevy dealer service dept wants $445 to replace the "blower resistor and connector" and say the connector(s) on the new module have to be changed as they are different than what I have. I guess that is why the estimate is so high - time changing the connector(s). Looking at YouTube this replacement looks pretty simple if the connectors don't need to be changed. What suggestions or comments do you have for me.
Thanks,
Neil
Submitted: 10 months ago.
Category: Chevy
Expert:  Ron Z. replied 10 months ago.

This is actually a "known problem" and GM had issued a "Special Policy Coverage Adjustment" for 10 years or 150,000 miles, whichever occurs first. The bulletin does state that the connector/harness and the resistor should both be replaced. The bulletin states the Labor to replace these items is .6hr. Labor rates vary from shop to shop, so what you pay for labor will effect the bot***** *****ne. For a job of this type, a "fair" labor rate can be anywhere from $85-$125 per hour. So, the estimate you received is definitely a bit high. You "CAN" correct the problem by just replacing the resistor itself as long as the electrical connector and harness have no signs of damage or melting. Keep in mind, after market resistors should plug-in correctly without the need to change the connector. However, due to the design of the old-style resistor, the life span may not be as long as it could be. If you found this answer helpful, please help me by leaving a rating using the "stars" at the top of the page or click 'accept'.
Rating or accepting my answer does not cost you extra. It allows me to be credited for this Q&A.

Expert:  Ron Z. replied 10 months ago.

Hi Gary! I noticed this thread was still open and you did not leave a rating , so I wanted to check in and see if there was anything else I could do for you on this issue? Did you have any other questions? Was there something I missed that you wanted addressed? If you have no further questions and simply forgot to leave a rating, please take a second and use the stars at the top of the page to rate our Q&A session. Thank-you!