How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Chevy
Satisfied Customers: 7476
Experience:  Since 1975
12769047
Type Your Chevy Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

94 k 1500 5.7 tbi, surge and stall when cold not so much

Customer Question

94 k 1500 5.7 tbi, surge and stall when cold not so much when hot. can't drive till hot and stumble up to 65 mph, then seems to gain legs and runs like hell if I don,t move the throttle. I have replaced everything except o2 sensor. this is a fresh long block and trans with distributor, alternator rebuilt tbi and fuel delivery from sending unit to tbi. smoked it this morning NO leaks, new ecm , ssdd. tried different ecm complete with chip, ssdd!!! HELP!!!!
JA: Have you located all of the vehicle's oxygen sensors? Are the wires leading to and from each intact and in good shape?
Customer: think there is only one befor cat and it wired properly
JA: What is the model/year of your Chevy?
Customer: 94
JA: What year is your Chevy?
Customer: 1994
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: read the first tread
JA: Anything else you think the mechanic should know?
Customer: needs a new assistant
Submitted: 9 months ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 9 months ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you.

does the engine light stay on?if so,can you give me the computer codes?

Customer: replied 9 months ago.
SES light comes on about 15 - 20 mins later code 44 lean mix.
egr blocked with plate
stop for a min restart enginge lights out and repeat
44 is stored not constant
Expert:  Tim's Auto Repair replied 9 months ago.

ok..does it run well out on the road?

does it run well at higher rpm's?

Customer: replied 9 months ago.
wot like a bat out of hell stumbles up to 65 mph
Expert:  Tim's Auto Repair replied 9 months ago.

ok..

when you say you have replaced everything,,please explain.

Customer: replied 9 months ago.
payments for that card has been sopped due to enterprise rentals dispute, nothing to do with you but no longer have charge account so we need to continue here
Expert:  Tim's Auto Repair replied 9 months ago.
ok..when you say you have replaced everything,,please explain.
Customer: replied 9 months ago.
long block, distributor, map, temp, tps, aic, coil,
have new o2 not in yet and knock not in yet
Expert:  Tim's Auto Repair replied 9 months ago.

and the 44 code is the only code you get,,,right?

Customer: replied 9 months ago.
correct
Expert:  Tim's Auto Repair replied 9 months ago.

ok.

does the power brakes feel good?

Customer: replied 9 months ago.
aside from needing pads and shoes yes good hard pedal, no change in performance when in use, also part of smoke test this morning, no leaks
Expert:  Tim's Auto Repair replied 9 months ago.

ok

from the way you explain..i have a couple of thoughts..

Customer: replied 9 months ago.
i'm desperate what are they???
Expert:  Tim's Auto Repair replied 9 months ago.

sense you get the 44 code,we know the engine isnt getting enough fuel or is getting too much air

Expert:  Tim's Auto Repair replied 9 months ago.

so i would think that the gasket under the throttle body is bad or the ect[engine coolant tempeture] sensor is bad

Customer: replied 9 months ago.
both are new and working
Expert:  Tim's Auto Repair replied 9 months ago.

you do have the egr blocked correctly and there is no way for it to get a vacuum from the exhaust,,right

Expert:  Tim's Auto Repair replied 9 months ago.

remove that plate and double check

Expert:  Tim's Auto Repair replied 9 months ago.

or you have a possible intake manifold leak

Expert:  Tim's Auto Repair replied 9 months ago.

it is getting air from somewhere

Expert:  Tim's Auto Repair replied 9 months ago.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/ystxn8y8xbkt541/0729-chevy-DTC%2044%20Chart.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/ystxn8y8xbkt541/0729-chevy-DTC%2044%20Chart.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 9 months ago.
correct plate between egr and gasket to manifold, smoke would have been coming out of the valve covers if internal, absolutely no exteral leeks
Customer: replied 9 months ago.
if your as stumped as I am please ask everyone there, I'm ready to shoot this beast and scrap some $7000,00 I've invested
Expert:  Tim's Auto Repair replied 9 months ago.

if you are certain you have no leaks,,then you arent getting enough fuel at low rpm's..the two injectors may be dirty or the new tps just isnt any good..

there isnt anything else left on this engine,,it doesnt have allot

Expert:  Tim's Auto Repair replied 9 months ago.

make sure you have a good vacuum to the map sensor and that the map sensor is good

Customer: replied 9 months ago.
new injectors and to verify used a known good regulator and injector set, map is new
Expert:  Tim's Auto Repair replied 9 months ago.

stand by..i willl opt out..

Customer: replied 9 months ago.
vacuum to map verified with guage holding around 20 in at idle hot and drops to around 5-6 when gunned comes back to 15- 20 at speed
Customer: replied 9 months ago.
that's with no load in park
Expert:  rpmdiag replied 9 months ago.

Hi, welcome to Just Answer. I’m Ron and I’ll be helping you
today.
Before we get started though, Please understand that I don't know
your skill level or tools you have to assist us. Also understand that
I can't see, smell, hear, or touch the vehicle either, so patience is
appreciated. JA is a great Q/A site, but it does NOT replace a
repair shop.
My goal is to make you happy and get a great rating in return for
my time. Sometimes I have to give you bad news that I know you
didn’t want to hear, so please don’t shoot the messenger.

New expert here.

You don't have a vacuum leak, you have a NOT enough fuel on a cold start issue causing 44 code. My opinion is that the wrong program chip is in that computer. Everything is working fine for a different motor, but not this one. You may want to use the CAL PAK for the engine that was in the other truck.

Thanks, Ron

Customer: replied 9 months ago.
Yeah, I thought of that to, took ecm and chip out of 94 suburban w 350 engine, running the suburban perfect, same lean condition in mine. Mind you I can't shift the trans to test drive because they are different 4l60 vs 4l80,
Expert:  rpmdiag replied 9 months ago.

Okay, then I'll opt out for you and pass this on again. Sorry I couldn't help, stay tuned.

Ron

Customer: replied 9 months ago.
the latest, r & r intake manifold gaskets, tbi gasket, no change. figured electrical, r & r cap rotor icm, no change tomorrow will change back to old distributor with known working pick up, will let you know. BTW, picked up an another truck same as mine and the spray pattern was the same, mine, after it got to opp temp still went lean. still working on it.
Customer: replied 9 months ago.
Changed distributor, no change, used known good map, no change, changed knock sensor, no change, did a comp test on brand new crate rebuild within 2 psi @ 150 psi with 9 cranks, screw it the only thing left is a brand new set of INJECTORS, took the entire throttle body off second truck and have been running all over town for the last 3 hours without a hitch.
DON'T TRUST NEW PARTS, CHECK AND RECHECK EVERYTHING NO MATTER WHAT!!!!!!!
I do thank you both for your help and if you have any questions please don't hesitate to ask

Related Chevy Questions