How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Chevy
Satisfied Customers: 23745
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Chevy Question Here...
Dan is online now
A new question is answered every 9 seconds

I have a 2004 Chevy Venture V6 3.4. It starts

Customer Question

I have a 2004 Chevy Venture V6 3.4. It starts intermittently, but will always crank. If it is any help the fuel guage doesn't work, but I am not worried about that unless it helps diagnose the problem. Usually it starts on the second try but if not we have to spray with starter fluid. I just want this car to last 1 1/2 years more.
JA: Has the vehicle turned into a gas hog? And how does it start -- same as usual?
Customer: Not a gas hog that I have noticed. When it starts, it starts great and the engine runs fantastic, when it is going.
JA: What is the model of your '04 Chevy?
Customer: Venture mini van
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Son-in-law has tried two different scopes and replace camshaft positioning sensors. fuel pump, plugs, fuel pressure sensor.
JA: Anything else you think the mechanic should know?
Customer: The scopes are now saying that there is a ground fault.
Submitted: 9 months ago.
Category: Chevy
Expert:  Dan replied 9 months ago.

Hello, my name is***** fact it starts with starting fluid means fuel pump is weak. It takes more pressure to start vehicle then to keep it running which is why this works. You can check fuel pressure, it should be at least 52 psi key on engine off, if low replace the pump. Here are replacement instructions which will also fix gauge issue. Let me know if you have more questions, thanks.

-

https://www.dropbox.com/s/9qwasvwd5irz2oa/fprra.pdf?dl=0

-

https://www.dropbox.com/s/b3h7ms3tmlfyf8j/fprrb.pdf?dl=0

Customer: replied 9 months ago.
It is a brand new fuel pump
Expert:  Dan replied 9 months ago.

How long ago was it replaced? Were you having problems before and right after replacing? Thanks.

Customer: replied 9 months ago.
1 week and problems before and after.
Expert:  Dan replied 9 months ago.

Is check engine light on? Are you setting any codes? Thanks.

Customer: replied 9 months ago.
check engine light is on. As far as codes, it originally said crankshaft positioning sensor ( changes both) now it says ground fault?
Expert:  Dan replied 9 months ago.

What is the actual code number?

Customer: replied 9 months ago.
crankshaft sensor was on hand held scope and ground fault on big scope. I am calling for the number.
Expert:  Dan replied 9 months ago.

Ok, thanks.

Customer: replied 9 months ago.
Code was 113
Expert:  Dan replied 9 months ago.

This code is related to the engine coolant temp sensor which can cause the problem you are describing so I'd go ahead and replace the coolant temp sensor at this point. Let me know how it goes or if you have more questions, thanks.

Expert:  Dan replied 9 months ago.

Give me a minute to look into it. Thanks.

Expert:  Dan replied 9 months ago.

This vehicle is related to the intake air temp sensor but I doubt that would cause the hard start. I'd go ahead and replace just since it is throwing code but then I would recommend going back to a fuel pressure test. Since vehicle starts with starting fluid we know problem is fuel related which would mean wiring problem causing low voltage to pump, weak pump even though new, fuel filter, or fuel pressure regulator. So if pressure is too low then I'd replace filter and check pressure again at filter. If good at filter but low at test port then replace fuel pressure regulator. If low at filter this means problem is wiring or new pump so check to make sure pump has good power/ground and if so replace. Let me know how it goes or if you have more questions, thanks.