How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Bob Your Own Question
GM Bob
GM Bob, ASE Certified Technician
Category: Chevy
Satisfied Customers: 964
Experience:  30 plus years. experience as GM technician, ASE Master Technician and GM Certified.
70078276
Type Your Chevy Question Here...
GM Bob is online now
A new question is answered every 9 seconds

2005 Chevy Tahoe just up and died while we were doing 30mph

Customer Question

2005 Chevy Tahoe just up and died while we were doing 30mph on a residential street. No problems before. No fuses blown. Will not even turn over. No clicks either. All kinds of strange warning lights and messages on the dash. OBD will not read any code, not just no code, but stuck on the asterisk *. Parking lights remain on even though no key is inserted until battery is drained. Purchased new ECM, but gun shy of installing it because of the warning in the package stating something else may be wrong. Any suggestions?
Submitted: 4 months ago.
Category: Chevy
Expert:  nathan thompson replied 4 months ago.

Have you checked the battery connections?

Customer: replied 4 months ago.
they are in good condition. no corrosion.
Expert:  nathan thompson replied 4 months ago.

try doing a visual inspection of the wiring harness and look for any obvious signs of damage, and also look at any ground connections you can find and see if they are secure

Customer: replied 4 months ago.
Just did that for everything under the hood. no worn wiring harness areas. all looks as it should be. nothing touching where it shouldn't (like against the exhaust, etc).
Expert:  nathan thompson replied 4 months ago.

let me do some digging and i will be back with you shortly

Expert:  nathan thompson replied 4 months ago.

Check these 2 grounds as best as possible, make sure they are good and tight

Customer: replied 4 months ago.
checking..
Expert:  nathan thompson replied 4 months ago.

Okay, let me know what you find.

Customer: replied 4 months ago.
they look / feel ok..connections are tight.
Expert:  nathan thompson replied 4 months ago.

check the pcm-b fuse. the pcm gets power from that circuit

Customer: replied 4 months ago.
I will check again, but I tested all fuses before. the ones in the engine compartment and the driver side panel.
Expert:  nathan thompson replied 4 months ago.

Also check to see if that fuse is getting power

Customer: replied 4 months ago.
I just want to check if there is anything else that someone knows of before I install the new (rebuilt) ECM. The instructions say there may be something else that caused the original ECM to go bad, and installing the new one without verifying will void the warranty.
Customer: replied 4 months ago.
I still think it was the ECM that went bad.
Expert:  nathan thompson replied 4 months ago.

If that fuse is getting power and your grounds are good then it probably is the ecm. If that fuse isnt getting power then it is likely the fuse block itself in the engine compartment.

Expert:  nathan thompson replied 4 months ago.

If you have any more questions please let me know, I will be happy to help.

Customer: replied 4 months ago.
All the fuses are good. I would think at least one of them should have blown if there was a problem.
Expert:  nathan thompson replied 4 months ago.

I agree, if there was a short then the fuse would have blown.

Customer: replied 4 months ago.
Then you would recommend the installation of the new ECM?
Expert:  nathan thompson replied 4 months ago.

I would give it a try at this point, you have checked the most common scenarios.

Customer: replied 4 months ago.
I will let you know the results. Thanks!
Expert:  nathan thompson replied 4 months ago.

You are welcome!

Customer: replied 4 months ago.
still won't crank. I do hear some abnormal noise from the fuel pump though. I guess it wasnt the ECM. I'll try again later.
Expert:  GM Bob replied 4 months ago.

Hello my name is Bob.

Do you still need help?

Related Chevy Questions