How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike S. Your Own Question
Mike S.
Mike S., Chevy Mechanic
Category: Chevy
Satisfied Customers: 6806
Experience:  ASE Certified Master Technician
20625509
Type Your Chevy Question Here...
Mike S. is online now
A new question is answered every 9 seconds

I HAVE A 2001 CHEVY BLAZER. MY ENGINE LIGHT CAME ON WITH

Customer Question

I HAVE A 2001 CHEVY BLAZER .
MY ENGINE LIGHT CAME ON WITH ERROR CODE P0410.I WOUND UP REPLACING THE SECONDARY VACUUM PUMP AND THE FUSE AND THE 30 AMP FUSE AS WELL AS THE RELAY ..A COUPLE DAYS LATER THE LIGHT CAME BACK ON SO I BROUGHT IT IN FOR DIAGNOSTICS ...THEY TOLD ME THE PUMP SOLINIOD WAS BAD AS WELL AS THE NEW PUMP WASNT WORKING MECHACNLY ..
SO I REPLACED THE PUMP AGAIN AND PUT A NEW SOLINIOD IN. ..
2 DAYS LATER THE LIGHT CAME BACK ON ... P0410 X2 ..
.
SO WHAT DO I DO NOW SIR...
THANK YOU
Submitted: 4 months ago.
Category: Chevy
Expert:  Mike S. replied 4 months ago.

First of all, stop replacing parts until you know what to replace and follow the Diagnostic Procedures in this article, if you have any questions feel free to reply. This is for the 4.3, if that has a different engine, let me know.

Customer: replied 4 months ago.
ok i guess ill go back thru and look.
however i have replaced all the parts already . so its to late to stop.
just thought something might pop out to you .
thank you .
Expert:  Mike S. replied 4 months ago.

you are welcome.

Customer: replied 4 months ago.
i found a blown 10 amp fuse right by the pump relay and 30 amp fuse behind the battery ,
i replaced it . it seems to be working now.
however what is that 10 amp fuse in that block operate . and what caused it to blow.
thanks
Expert:  Mike S. replied 4 months ago.

You never told me which fuses they were but I suspect they are the 2 in this diagram that feed that secondary air injection pump, the "air sol" fuse and the "air relay". Normally a fuse blows when something on the circuit is short circuited, like when the copper windings in a motor short circuit, or when any wire for that matter touches ground or another wire, due to the insulation that burnt off or rubbed off.

Customer: replied 4 months ago.
right behind the batterry there is a block inside of the fender that pulls out.
it houses the pump relay and a 30 amp fuse for the pump and then a 10 amp fuse.
i dont know what the 10 amp fuse is.
Expert:  Mike S. replied 4 months ago.

I believe that 10a fuse is the "air sol" fuse at the top of that second wiring diagram, this one and it goes to the "air relay". The 30a is most likely the "air fuse".

Expert:  Mike S. replied 4 months ago.

Get it all fixed yet?

Customer: replied 4 months ago.
no . i already replaced the check valves on both sides , . the soiniod. the pump . all the fuses . and it sounds like it working , however now the 10 amp fuse pops.i brought it into a shop . and they told me i needed a new pump and a soliniod. . i told them they are both new and they said they are working but not mechanicacly working, .
whatever that means , i dont know .
seems like a waist 0f $125 ./
what do you think ,.
the only that that i know i havent replaced is the air hoses to and from the pump nor the wiring , .
but like i said, the pump starts up and runs for around 1 minute and shuts off , just like it is suppose to.