How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Don 'Mo Lurch' Your Own Que...
Don 'Mo Lurch'
Don 'Mo Lurch', Auto Mech / Electronics
Category: Chevy
Satisfied Customers: 20753
Experience:  Chevrolet Cert., Heavy Line Mech, Race Shop Owner, Mobile Electronics.
1609972
Type Your Chevy Question Here...
Don 'Mo Lurch' is online now
A new question is answered every 9 seconds

Have a 2007 chev uplander van, the altinator has been

Customer Question

hi
JA: Hello. What is your issue regarding?
Customer: have a 2007 chev uplander van
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: the altinator has been replaced and the battyery and the light stil;l says charging system failure
JA: Have you tested the battery? Is the battery fluid low?
Customer: new battery and have replaced the altinator two times
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chevy Mechanic about your situation and then connect you two.
Customer: thinking maybe the replacement was bad
Submitted: 9 months ago.
Category: Chevy
Customer: replied 9 months ago.
Expert:  Don 'Mo Lurch' replied 9 months ago.

.
Greetings...... “Hi, I’m Don (akaCustomer and I look forward to helping you!”
.
This is typically caused from the Voltage Regulator & / or the ECM
IF you have replaced the Alternator & Voltage Regulator, then the ECM needs to be Tested prior to any other Parts.
Use of GM or equal Scan Tool is needed to Test the ECM, as the ECM receives a signal from the Voltage Regulator to turn on the Light.
IF you have already replaced the Voltage Regulator, then the chances are greater that the ECM is the issue
You canchec the ORANGE wire at the Alternator for loose connection or no connection & if that looks good, then you need Scan Tool to Test Charging Circuit to pinpoint the issue
apprx 1 hour labor

.
IF you need more information, please ask "prior" to Rating.
.
The way it works:
Once an answer is given, "you" as the customer, are expected to "RATE" the answer as you agreed to do.
.
Please do the right thing and leave a rating, using the rating system, so I may be credited for this Q&A.
.
NOTE: Do NOT Rate on how much TIME you waited, because I am not on 24 / 7 and I answer as soon as I see the question.
The question will still remain open for follow up questions if needed.
.
If for any reason, you can't rate my answer OKAY, GOOD, or EXCELLENT today.
Please reply and let me know why, so I can help more/better.
.
Rating is very Important to our Service
.
.

Expert:  Don 'Mo Lurch' replied 9 months ago.

Be sure to test the RED (big) Battery wire for Voltage + Constant....
IF there is no Voltage +, then the Fusible Link is bad at the Starter
The RED wire on the Alternator goes to the (+) of the Battery to charge Battery

Expert:  Don 'Mo Lurch' replied 9 months ago.

.
Please do the right thing and leave a rating, using the rating system, so I may be credited for this Q&A.
.
NOTE: Do NOT Rate on how much TIME you waited, because I am not on 24 / 7 and I answer as soon as I see the question.
The question will still remain open for follow up questions if needed.
.
If for any reason, you can't rate my answer OKAY, GOOD, or EXCELLENT today.
Please reply and let me know why, so I can help more/better.
.

Expert:  Don 'Mo Lurch' replied 9 months ago.

clearly there still must be a problem
You have read my answer & not responded

please respond so I can help further, or at least let me know what you found
Rating answer is what was agreed on
.