How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I'm working on a 1994 6.5TD, with shifted ECT readings. On a

Customer Question

Hello. I'm working on a 1994 6.5TD, with shifted ECT readings. On a 90 day Modis scan tool shows 200 degrees. checked all grounds, replaced ECT 2 reman computers & 1 out of a junkyard. I get the same readings. Disconnect ECT & Scanner reads -7 degrees. Disconnect IAT reads -40, as they both should. Removed ECT wire From PCM, still reads -7 degrees. Any Ideas. Thanks fro your help ! Jim
JA: Have you checked all the fuses? Do you have a wiring diagram?
Customer: Yes
JA: What is the model of your '94 Chevy?
Customer: C3500
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Yes. Please reread my initial post.
JA: Anything else you think the mechanic should know?
Customer: Not @ the moment. Thanks
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chevy Mechanic about your situation and then connect you two.
Submitted: 5 months ago.
Category: Chevy
Expert:  Juan Crespo replied 5 months ago.

Hi there.

I'm sorry, but I'm a bit confused - being a retired GM tech, I'm used to the Techs 1 and 2 and not familiar with Modis. So, putting all the Modis stuff aside, what is it you're trying to diagnose?

Customer: replied 5 months ago.
Cold engine. 90 Degrees today .Pcm shows ECT @ 200 Degrees. when ECT disconnected Any Scanner should show -40. Same as disconnected IAT. Disconnected ECT Signal wire at Pcm to rule out wiring short or ground .Still @ -7. So all ECT temp.readings are shifted by 100 degrees. reconnect all wiring , put a new ECT in Ice water, PCM reads 140 degrees.
Expert:  Juan Crespo replied 5 months ago.

I'm sorry, but I still don't understand what it is you're trying to fix; is it a drivability issue or is it a problem with a gauge not reading accurately? In other words, what was it that compelled you to hook up your scan tool and look at temperature readings?

Customer: replied 5 months ago.
Can you refer me to another Tech?
Expert:  Juan Crespo replied 5 months ago.

I will opt out and open your question back to the field. Please do not reply or the site will cycle this back to me.

Expert:  GM Bob replied 5 months ago.

Hello my name is ***** ***** I can help.

Do you have a ohm meter.

Here is a chart of Temperature Versus Resistance of the coolant sensor. I know it shows it for a 1996 but it is the same.

https://www.dropbox.com/s/0bykmu5vsq1viy7/Temperature%20Versus%20Resistance.pdf?dl=0

Please get back with me