How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Chevy
Satisfied Customers: 22534
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Chevy Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

09 Silverado 6.6 diesel crank no start. no power or signal

Customer Question

09 Silverado 6.6 diesel crank no start. no power or signal at injectors. checked cam and crank signal at pcm good pattern on both not sure if aligned correct for timing tech 2 says there in sync and getting signal
JA: What size is your engine?
Customer: 6.6
JA: What is the model/year of your Chevy?
Customer: 2009
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: yes.. pcm
JA: Anything else you think the mechanic should know?
Customer: not at the moment..
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chevy Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Chevy
Expert:  Juan Crespo replied 1 year ago.

Hi there.

Both power and ground circuits to the injectors are controlled by the PCM. Going by your description of "no power or signal to the injectors", I would say either the PCM itself is bad or there is a connection/harness problem between it and the injectors. Do you have access to a Tech-II or equivalent scan tool? Have you checked continuity between the injectors and the PCM?

Customer: replied 1 year ago.
We have a tech 2, checked for signal at the pcm, checked all powers and ground at the pcm found used pcm tried it no difference
Expert:  Juan Crespo replied 1 year ago.

Once again, have you checked continuity on the harness and connectors between the injectors and the PCM?

Can you activate individual injectors through the Tech-II?

Expert:  Juan Crespo replied 1 year ago.

Did you check with the Tech-II to see whether or not the anti-theft immobilizer is preventing the engine from starting?

Customer: replied 1 year ago.
it's good not active, this model will not crank with theft active
Customer: replied 1 year ago.
Did not check the resistance, and cannot activate injectors
Expert:  Juan Crespo replied 1 year ago.

In that case, I’m sorry, but I don’t have any other information that could help you at this time. I’ll opt out so others may try. Please do not reply until another expert responds or the site will cycle this request back to me.

Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

Do you still need help?

Customer: replied 12 months ago.
Expert:  sprinkles08 replied 12 months ago.

What are actual and commanded rail pressure while cranking?

Customer: replied 12 months ago.
commanded is seven thousand actual is around eight thousand
Expert:  sprinkles08 replied 12 months ago.

Did the problem start after a repair, jump start, accident, etc?

Customer: replied 12 months ago.
customer told me he was driving down the road, one thing I noticed was he has a after market exhaust system so the temp sensor are missing so is the harness, they read 1200 deg f on the tech2 . was wondering if that would shut the injectors down but I didn't pay much attention to it cause the exhaust was was on it for a while. the truck is new to him
Expert:  sprinkles08 replied 12 months ago.

Is there a security light on or flashing?

Customer: replied 12 months ago.
No, it's got one code for the key I'll find out what it is tomorrow, but the theft system on this truck will keep the truck from cranking,i replaced the pcm and tried starting it before programmed the theft module, wouldn't crank
Expert:  sprinkles08 replied 12 months ago.

If there is an active code related to the key that's definitely a concern.

Customer: replied 12 months ago.
I'll get the code tomorrow, but I created this code when I replaced the pcm
Expert:  sprinkles08 replied 12 months ago.

Regardless of how it started if you have a code related to the key it needs to be dealt with before proceeding.

Customer: replied 12 months ago.
Put the original pcm back in there one code p0676 glow plug 6 control circuit. Still no start
Expert:  sprinkles08 replied 12 months ago.

What are the injector pulsewidths while cranking?

Customer: replied 12 months ago.
Put a glow plug in for six took care of that code, didn't show pulse width, but I have 46mm3 for base injector fuel rate when cranking. Then it reads 0 balance rate while cranking on all 8 injectors
Expert:  sprinkles08 replied 12 months ago.

The fuel rate does go back to zero when not cranking?

Customer: replied 12 months ago.
Expert:  sprinkles08 replied 12 months ago.

Have the injector circuits been tested for an open circuit, a short to power or ground?

Customer: replied 12 months ago.
Never check that we unplugged each injector and it set a code, then checked for signal at the pcm
Expert:  sprinkles08 replied 12 months ago.

Was injector resistance tested?

Customer: replied 12 months ago.
Load tested all injector wires with a head light, checked for short to ground, ohm out injectors all around 2.4
Expert:  sprinkles08 replied 12 months ago.

How did you determine the injectors are not receiving signal?

Customer: replied 12 months ago.
There's nothing coming out the pcm or at the injectors no power or signal tried leaving the injectors plugged in and back probing them
Expert:  sprinkles08 replied 11 months ago.
Exactly how was testing done?
Customer: replied 11 months ago.
Load tested each wire with 12 volts to a head light checked the resistance at the injectors unplugged with a ohm meter
Expert:  sprinkles08 replied 11 months ago.

Signal. Please explain exactly what was done and the results seen.

Customer: replied 11 months ago.
The wiring is good from the pcm to injectors the injectors ohm out 2.4-3.2 ohms
Expert:  sprinkles08 replied 11 months ago.

I do understand that, I'm asking for specifics on what you did that you believe the injectors are not getting signal.

Related Chevy Questions