How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chad Farhat Your Own Question
Chad Farhat
Chad Farhat, ASE Certified Technician A6 - Electrical / Electronic systems A7 Heating / Air conditioning systems
Category: Chevy
Satisfied Customers: 2979
Experience:  Owner at Carolina Auto Service & Sales , 20 years Experience in Foreign & Domestic vehicles A6 - Electrical / Electronic systems A7 Heating / Air Conditioning systems
45790705
Type Your Chevy Question Here...
Chad Farhat is online now
A new question is answered every 9 seconds

I have a 2007 Avalanche 1500. The vehicle sat (3 months)

Customer Question

Hello, I have a 2007 Avalanche 1500.
The vehicle sat for awhile (3 months) while we were out of town.
We had to jump the vehicle when we returned and it started no problem.
after driving to the fuel station the vehicle would not start. Went to buy a new battery and it started right up. Noticed the power fluctuating at first but then no problems until later the next day after driving a few hours.
Parked the vehicle for a moment and again no start. The battery was new. tried to get a spark from the battery and nothing. took out the battery from another vehicle and again nothing. Put the battery back in the other vehicle and it started right up.
No power at all. Someone said something about the fusible link at the passenger side firewall? Any help would be appreciated. Thank you.
Submitted: 11 months ago.
Category: Chevy
Expert:  Chad Farhat replied 11 months ago.
Hi my name is ***** ***** I will be assisting youDo you have a voltmeter so we can check if that alternator is charging 14V while running
Is there any check engine light on dash
Cause the new battery u installed should not have died that quick, unless altantor not charging and especially you drove itLet me know
Thank you
Chad ( akaCustomer
Customer: replied 11 months ago.
no check engine light, no lights at all because there is no power. I'd have to go buy a V.M.
Expert:  Chad Farhat replied 11 months ago.
Also if u have a test light we can check the under hood fuse in case main fuse blew for alternator
If u have a test light check this fuse box
Expert:  Chad Farhat replied 11 months ago.
Fuse bloc under hood
Expert:  Chad Farhat replied 11 months ago.
Label 1
Expert:  Chad Farhat replied 11 months ago.
Expert:  Chad Farhat replied 11 months ago.
Expert:  Chad Farhat replied 11 months ago.
Expert:  Chad Farhat replied 11 months ago.
Expert:  Chad Farhat replied 11 months ago.
Expert:  Chad Farhat replied 11 months ago.
Ok Let me know , I m online till midnight tonight till 12 pm
Chad aka -Customer