How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete, Auto Service Technician
Category: Chevy
Satisfied Customers: 24210
Experience:  14 years GM dealer Technician.
Type Your Chevy Question Here...
Pete is online now
A new question is answered every 9 seconds

Just put fuel pump in got fire on wire on pump but pump not

Customer Question

just put fuel pump in got fire on gray wire on pump but pump not pumping gas
Submitted: 4 months ago.
Category: Chevy
Expert:  Pete replied 4 months ago.

Hi,my name is ***** ***** I will be happy to try to assist you with this.I may need more information in some cases to help with answering your question.

Expert:  Pete replied 4 months ago.

Test the black wire for a ground signal at all times at the pump.If you have no ground signal then this ground wire is damaged or disconnected.It usually connects around the tank area on the frame so trace it and see if you locate the issue with it needing repaired or replaced.If found to be o.k. you might try and add another ground to this wire and see if your pump then runs and operates.If the ground is o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Chevy Questions