How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Chevy
Satisfied Customers: 4679
Experience:  Owner at DJ Wilson
65405794
Type Your Chevy Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

I have a 1991 motor home with a 454 Chevy motor. Will start

Customer Question

I have a 1991 motor home with a 454 Chevy motor. Will start and run but will not idle. If I disconnect the map sensor vacuum line will idle but as soon a I put it into gear, will die. I have replaced the ECU, map sensor, coolant temp sensor, fuel filter, throttle position sensor, distributor,
Submitted: 10 months ago.
Category: Chevy
Expert:  Daniel Wilson replied 10 months ago.

Hi Dan, My name is***** will be glad to try to help. What are you getting for fault codes and also have you verified consistent fuel supply pressure and no restrictions or leaks?

Customer: replied 10 months ago.
Hi dan, I can't check fault codes. I am broke down in a small town with no mechanics. At least they have a parts store. I haven't checked the fuel pressure yet. Will buy a gauge.
Customer: replied 10 months ago.
Anything else I might look for. Its about 5 mile walk to the store. I've made it about 8 times.
Expert:  Daniel Wilson replied 10 months ago.

Verify good fuel delivery while cranking and the line into a container since you are on the side of the road. Check if either a mechanical fuel pump on the engine block or the electrical on yours. If electrical be sure it is coming on. if fuel is good and you have spark, verify you are in time and compression is good. Otherwise the engine should start.Crank sensor problems will cause a no start as well

Customer: replied 10 months ago.
I checked the fuel pressure. Pump is in the tank. Pressure at start is 4 lb and then dropped to 3 lb and held. Engine starts and can rev up but dies as soon as I put it into gear.
Customer: replied 10 months ago.
The only way it will idle is with the map sensor vacuum line disconnected and pluged.
Expert:  Daniel Wilson replied 10 months ago.

Try disconnecting the EGR valve

Expert:  Daniel Wilson replied 10 months ago.

A faulty IAC will cause the symptoms you are having if the timing and other items you posted have been already eliminated.

Customer: replied 10 months ago.
I have replaced egr and the iac. Each time I replaced any item I would start the motor and still would not idle or stay running.
Customer: replied 10 months ago.
Do you know why it will idle when map vacuum line disconnected but die when I put it in to gear or reconnect the vacuum line? Should 3 psi fuel be enough?
Expert:  Daniel Wilson replied 10 months ago.

For throttle body you should have 45 + PSI... if not its a faulty pump or pressure regulator.

Expert:  Daniel Wilson replied 10 months ago.

Around 5 PSI is okay for carbureted engines.

Expert:  Daniel Wilson replied 9 months ago.

Hi, Correction. TBI these years were 12-15 PSI but not more than 15 PSI. You have a weak pump, Leaks, or pressure regulator problem