How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15133
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

My name is ***** ***** I have a similar problem with my

Customer Question

Hi, my name is ***** ***** I have a similar problem with my transmission. I have a 1998 Chevy S10 ZR2 4x4. I changed the trans fluid and filter. When I put everything back together, I shifted through all the gears but it would not go back into park. I adjusted the linkage by the trans side and checked the cable hook up under the dash and all looks good. I even bought a new cable thinking that might be the problem but the same thing happens. I tried putting it N and the trans too from trans and adjusted the cable for both being in N but the problem was still the same.
Submitted: 6 months ago.
Category: Chevy
Expert:  chevygeorge replied 6 months ago.
Hello. My name is ***** ***** I'm here to assist you.If you disconnect the shift cable, can you manual put it in Park the shift lever? If not and no other components were changed, is it possible the filter assembly got out of position in the pan, and is physically interfering with the shift pawl?