How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15133
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevrolet Silverado 1500 Classic LT: I have a 2005 silverado.

Customer Question

I have a 2005 silverado. It's set up with trailer brake controller. I noticed I was getting no activation on my brake controller. I them checked for all other brake lights. I had none. I bought the brake light switch and replaced it. I had previously replaced the pig tail that comes out of it. Before replacement i would get brake lights when pedal was almost to the floor. Now nothing. If I manually activate my trailer brakes I have lights. Any ideas?
Submitted: 6 months ago.
Category: Chevy
Expert:  CHRIS ZAPANTIS replied 6 months ago.
did you properly adjust the brake light switch?
Customer: replied 6 months ago.
How is that done?
Expert:  CHRIS ZAPANTIS replied 6 months ago.
give me a minute
Expert:  CHRIS ZAPANTIS replied 6 months ago.
by pushing it all the way in with the brake pedal down then release pedal and it will push it to where it needs to go
Customer: replied 6 months ago.
I just tried that. It did not make a difference
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok do you have a dvom?
Customer: replied 6 months ago.
A cheap one, yes
Expert:  CHRIS ZAPANTIS replied 6 months ago.
also can you get me the VIN?
Customer: replied 6 months ago.
1GCEK19B05E144815
Expert:  CHRIS ZAPANTIS replied 6 months ago.
cheap is good lol
Expert:  CHRIS ZAPANTIS replied 6 months ago.
gimme a minute i will pull up diagram for brake lights
Expert:  CHRIS ZAPANTIS replied 6 months ago.
is the third break light working?
Expert:  CHRIS ZAPANTIS replied 6 months ago.
orange wire pin b of brake light switch is ther voltage?
Expert:  CHRIS ZAPANTIS replied 6 months ago.
make sure key is on
Customer: replied 6 months ago.
Key is on, no third brake light
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok orange wire at pin b of break light is ther voltage? how much?
Customer: replied 6 months ago.
Sorry for not understanding, how exactly do I check that with the harness plugged in
Expert:  CHRIS ZAPANTIS replied 6 months ago.
go in throught the back of the connector or pierce the orange wire
Customer: replied 6 months ago.
The most it seemed to show was.02
Expert:  CHRIS ZAPANTIS replied 6 months ago.
oh oh no power to switch
Expert:  CHRIS ZAPANTIS replied 6 months ago.
check veh stop fuse right there in the interior fuse panel.
Expert:  CHRIS ZAPANTIS replied 6 months ago.
it says VEH STOP
Customer: replied 6 months ago.
I was able to reposition. Ingot 11.58. But I'll check fuse too
Customer: replied 6 months ago.
Fuse is good
Expert:  CHRIS ZAPANTIS replied 6 months ago.
oh if you got 11.58 its good
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok now press brake pedal and check for voltage at white wire pin A
Expert:  CHRIS ZAPANTIS replied 6 months ago.
does it have 11.58?
Customer: replied 6 months ago.
11.26
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok we now know that your brake switch and everything before is working
Expert:  CHRIS ZAPANTIS replied 6 months ago.
look in your door sticker is your truck over 8600 gross weight or under?
Customer: replied 6 months ago.
Under. 6400lb
Expert:  CHRIS ZAPANTIS replied 6 months ago.
also rear drums or discs?
Customer: replied 6 months ago.
Drums
Expert:  CHRIS ZAPANTIS replied 6 months ago.
having trouble getting right diagram they have 100 different options
Customer: replied 6 months ago.
I understand
Expert:  CHRIS ZAPANTIS replied 6 months ago.
you have a brown wire going in to your switch?
Customer: replied 6 months ago.
Yes
Expert:  CHRIS ZAPANTIS replied 6 months ago.
check for power
Customer: replied 6 months ago.
It appears no
Expert:  CHRIS ZAPANTIS replied 6 months ago.
according to this diagram you have a bad 10 amp fuse in the instrument panel fuse block
Expert:  CHRIS ZAPANTIS replied 6 months ago.
put one end of your voltmeter to ground and with the other end touch the little metal pieces sticking out on top of the fuse if they have power on both sides they are good
Expert:  CHRIS ZAPANTIS replied 6 months ago.
if only on one they are bad
Expert:  CHRIS ZAPANTIS replied 6 months ago.
check them all especially 10 amp
Customer: replied 6 months ago.
All of the 10 amp fuses have power. The only one that seems to have no power is a 15amp with the label of ddm
Expert:  CHRIS ZAPANTIS replied 6 months ago.
it has no power on both sides?
Customer: replied 6 months ago.
I cannot get a reading on it
Customer: replied 6 months ago.
Disregard
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok
Expert:  CHRIS ZAPANTIS replied 6 months ago.
are your outside fuses marked?
Customer: replied 6 months ago.
Sorry, I must not have got a good connection the first time. It's dark out to which is fun
Expert:  CHRIS ZAPANTIS replied 6 months ago.
do you have a 25a that says STOP LP?
Expert:  CHRIS ZAPANTIS replied 6 months ago.
I HEAR YA!
Customer: replied 6 months ago.
The only 25 is the flash and windshield wiper
Expert:  CHRIS ZAPANTIS replied 6 months ago.
there has to be one maybe thats the problem someone put in a smaller fuse and it fried
Expert:  CHRIS ZAPANTIS replied 6 months ago.
you are talking about the outside box right?
Customer: replied 6 months ago.
Inside the truck
Expert:  CHRIS ZAPANTIS replied 6 months ago.
i may be running too fast and confusing you
Expert:  CHRIS ZAPANTIS replied 6 months ago.
we figured all were good inside now i want you to check the outside that says STOP LP its 25a
Customer: replied 6 months ago.
Ok. That one shows power to both sides
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok now go inside to brake switch and check black wire for voltage
Customer: replied 6 months ago.
There is no black wire
Customer: replied 6 months ago.
Purple, orange, green with white stripe, green with brown stripe, brown, whitems
Expert:  CHRIS ZAPANTIS replied 6 months ago.
i cant get the right diagram
Expert:  CHRIS ZAPANTIS replied 6 months ago.
from what weve done so far the problem has to be in the back
Expert:  CHRIS ZAPANTIS replied 6 months ago.
a common thing that happens is the wires in the back especially when theres a trailer hitch get damaged
Expert:  CHRIS ZAPANTIS replied 6 months ago.
im sure you cant see any of those connectors now. Can you pull out a tailight?
Customer: replied 6 months ago.
I can, but before I do so, of I slide the brake controller lever over and manually engage the trailer brakes i do have all break lights
Expert:  CHRIS ZAPANTIS replied 6 months ago.
can you see where it taps in?
Expert:  CHRIS ZAPANTIS replied 6 months ago.
forget about the rear lights now. lol
Customer: replied 6 months ago.
It uses a harness that makes it plug and play. It connects in the black "box" to the
left of the brake pedal
Expert:  CHRIS ZAPANTIS replied 6 months ago.
disconnect it see what happens
Expert:  CHRIS ZAPANTIS replied 6 months ago.
disconnect and press brake.
Expert:  CHRIS ZAPANTIS replied 6 months ago.
now it makes sense why cant get right diagram it has a factory installed trailer hookup
Customer: replied 6 months ago.
No change
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok plug it back in.
Expert:  CHRIS ZAPANTIS replied 6 months ago.
so with the brake pedal pressed you have voltage at the white wire on switch?
Customer: replied 6 months ago.
Yes. About 10.8
Expert:  CHRIS ZAPANTIS replied 6 months ago.
this is what i see
Expert:  CHRIS ZAPANTIS replied 6 months ago.
that white wore goes to the vehicle stop fuse and it comes back out and through the underhood fuse panel and it turns L BU whatever that color is
Expert:  CHRIS ZAPANTIS replied 6 months ago.
then it turns down and goes to the tailight connector
Expert:  CHRIS ZAPANTIS replied 6 months ago.
very possible you may have a bad connection in the underhood fuse box ide pull it and examine
Expert:  CHRIS ZAPANTIS replied 6 months ago.
do you want me to opt out and let someone else maybe that can help you better or you want to stick with it with me?
Customer: replied 6 months ago.
I'm to a point tonight where I can't devote any more tI me to it unfortunately
Expert:  CHRIS ZAPANTIS replied 6 months ago.
ok no problem
Customer: replied 6 months ago.
Thank you
Expert:  CHRIS ZAPANTIS replied 6 months ago.
good luck to you and thank you