How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Luke Your Own Question
Luke, ASE Certified Technician
Category: Chevy
Satisfied Customers: 11
Experience:  Technician at General Motors
Type Your Chevy Question Here...
Luke is online now
A new question is answered every 9 seconds

Chevrolet Suburban 1500 LTZ: i have 2007 Chevy Suburban LTZ

Customer Question

i have 2007 Chevy Suburban LTZ 1500. the wife was driving this car and service suspension came up on the dash. Have heard the compressor kick on at start up like it normally does. I checkecd the fuse under the hood, I checked the sensors on all 4 wheels to make sure on hadnt come undone and i have installed a new compressor still doesnt work. does the system need reset or is there something im missing?
Submitted: 6 months ago.
Category: Chevy
Customer: replied 6 months ago.
havent heard the compressor is what meant to say
Expert:  Luke replied 6 months ago.
HiI'm Luke and I'll try to help if I can. Do you have access to a scan tool so we can pull a code out of the system? You would need more than just a code reader as those only pull out codes from the engine and transmission. Once we have that we can start our diagnoses. Let me know when yo get a chance.
Customer: replied 6 months ago.
i only have a OBD and its part of my laptop
Expert:  Luke replied 6 months ago.
Ok, without one I can only tell you from experience what I have ran into on those systems. Let me ask, do those shocks have a sensor on them?
Customer: replied 6 months ago.
no just an air line. there is a ride height/level sensor at each wheel. on the rear the linkage is connected to the trailing arms that connect to the rear axel
Expert:  Luke replied 6 months ago.
To identify the system, can you tell me what the number of the fuse you are checking is? Is it a 10 amp or 30?
Customer: replied 6 months ago.
its a 30 amp fuse #2 positiion in the underhood fuse box.....Listed as Electronic Stability Suspension control, Automatic level control
Expert:  Luke replied 6 months ago.
Ok that is the compressor main power, there should be one other fuse which is fuse #54 a 10 amp SEO/ALC which is the signal from the run crank relay to the compressor. This is a pink wire. Check to see you have power on both of those lines back to the compressor. I will tell you I have seen many problems with the wiring in the back at the compressor plug itself where it has rubbed onto the frame. Check on those and I will have to check back with you tomorrow. Also be sure to check the grounds at the compressor
Expert:  Luke replied 6 months ago.
Sorry I had to leave unexpectedly last night. Did you get a chance to check those things out? Let me know when you can thanks
Expert:  Luke replied 6 months ago.
Just wondering if you have come up with anything on this one yet
Expert:  Luke replied 6 months ago.
I need for you to please give me a rating on this one so we can close it out. If i can assist you further please let me know thanks!

Related Chevy Questions