How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I change all the valve timing belt tensioner and the idler,

Customer Question

Hi ,i change all the valve timing belt tensioner and the idler, after everything's been done its start but when I turn it off and start it ,it won't start.
Submitted: 8 months ago.
Category: Chevy
Customer: replied 8 months ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 8 months ago.
I scan it there's a p0106 p0135p0107 and then later on p2610 came ut
Expert:  Jerry Newton replied 8 months ago.
What year and model is your Chevy?
Customer: replied 8 months ago.
2005
Expert:  Jerry Newton replied 8 months ago.
What model is it? Aveo? Malibu? etc.
Customer: replied 8 months ago.
Chevy Aveo 2005
Customer: replied 8 months ago.
Hello
Expert:  Jerry Newton replied 8 months ago.
Yes, OK. Bear with me, I'm helping several people at one time right now. Let me research this a bit and see what's going on. It doesn't start right now?
Customer: replied 8 months ago.
Yes
Customer: replied 8 months ago.
And it's not shifting properly
Expert:  Jerry Newton replied 8 months ago.
Did you remove any ground cables or anything like that while doing the timing belt?
Customer: replied 8 months ago.
No I didnt
Expert:  Jerry Newton replied 8 months ago.
OK. Two of those codes point to a MAP sensor issue, another one points to low voltage (which is why I asked about connections). And the last code points to an oxygen sensor heater. Give me a few more minutes to see if I can figure out a relationship between these things.
Expert:  Jerry Newton replied 8 months ago.
You've got a scan tool. Does it read live data? Can you turn the key on and give me some of the data items from the scan tool?
Customer: replied 8 months ago.
It's just pocket scanner,p0106,p2610
Expert:  Jerry Newton replied 8 months ago.
OK, that's not going to do us any good. Have you done a good visual inspection just to see that everything is plugged in? Have you checked fuses? I use a test light on fuses, to make sure there is actually power present at the fuses, you can just touch the tops of the fuses and the light should illuminate. I don't really have enough data to work with to make a connection here of what's wrong, so I would start with basics. It cranks but doesn't start? Does it have spark? Does it have fuel pressure? Use a gauge to measure fuel pressure, how much is there?
Customer: replied 8 months ago.
Now it start
Customer: replied 8 months ago.
Once I turn it off it's not gonna start again.
Customer: replied 8 months ago.
I checked all the fuse relays its ok
Expert:  Jerry Newton replied 8 months ago.
That's OK, you have to diagnose it while it won't start anyway. Any testing you do while it's working doesn't mean anything. Since it's sporadic, I'm inclined to look at battery cable connections and things like that, it has to be something pretty obvious, yes?