How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevrolet: . I have a 2010 2500 with a Duramax. Wont run

Customer Question

Hi. I have a 2010 2500 with a Duramax. Wont run at the moment? There was a code for low fuel pressure. If I leave fuel filter cap loose with key on, there is no fuel coming to the filter. Is there an electric pump somewhere? Frame rail or in the fuel tank? Any help would be appreciated. Thanks
Submitted: 8 months ago.
Category: Chevy
Expert:  SaabTech replied 8 months ago.
The fuel pump is located under the intake manifold. It acts as the supply and high pressure pump for the injectors. It is a mechanical pump so we can eliminate an electrical concern.Was it running and just died? Did you change the filter and then the problem developed? Get back to me and we can figure out the issue. Thanks
Customer: replied 8 months ago.

yes. The filter was changed and it has not run since? Filter was changed twice more. Bled as far as I know and still nothing. Now it has come to me. ??

Expert:  SaabTech replied 8 months ago.
There is a bleeder bulb on the fuel filter housing. I suggest removing the filter and filling it with fuel then rebreeding it with the bulb. Just pump a few times then try and start it. It should get enough fuel to run and then the engine will take over pulling the fuel up to the pump The fuel pump is located under the intake manifold. It acts as the supply and high pressure pump for the injectors. It is a mechanical pump so we can eliminate an electrical concern.Was it running and just died? Did you change the filter and then the problem developed? Get back to me and we can figure out the issue. Thanks
Customer: replied 8 months ago.

I believe the engine will start and run for about 5 seconds after it has been primed. Tried again and same result?

Expert:  SaabTech replied 8 months ago.
Did you fill the filter with fuel first? When trying to prime the pump, it will pull enough fuel to start for a few seconds but will quickly pull a vacuum in the filter if not full.
Customer: replied 8 months ago.

Thanks. We will try again

Expert:  SaabTech replied 8 months ago.
If that doesn't work, the next step is to take the pressure regulate off the pump and check for metal debris. I'm sending a picture, hope it goes through.