How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Newton Your Own Question
Jerry Newton
Jerry Newton, Chevy Technician
Category: Chevy
Satisfied Customers: 4410
Experience:  ASE Master Technician, L1, Master GM Technician. Over 20 years of bumper to bumper GM experience.
Type Your Chevy Question Here...
Jerry Newton is online now
A new question is answered every 9 seconds

I talked to you earlier and got some diagrams engine

Customer Question

I talked to you earlier and got some diagrams for my engine and transmission swap. I got everything together now and final got the motor to turn over, but can't get the engine to keep running. It starts and will run for a couple seconds then dies. Using HP Tumers I can verify the fuel pressure is good and I'm getting spark. Any advice on where to go from here? Thanks.
Submitted: 6 months ago.
Category: Chevy
Expert:  mike switzer replied 6 months ago.
this says engine swap were you changing engine size or just replacing the original. when it starts does it just start and dies right away?
Customer: replied 6 months ago.
I'm sorry for the confusion but I had requested for a different technician I had dealt with previously, as he already knows what I have been working on and all the customization items I have in place. I'm not sure how to proceed, but ideally I'd like to use my previous contact. Thank you.
Expert:  Jerry Newton replied 6 months ago.
Hello again. If you have HP tuners, this is easy: open HP tuners, and disable VATS. Reprogram the PCM with that new calibration, and this will start up. If you want to keep VATS, we can do a relearn, but HP Tuners allows you to just do away with it, if that's something you prefer.
Expert:  Jerry Newton replied 6 months ago.
It sounds to me like the engine computer is shutting off the fuel injectors due to a theft deterrent issue, so you can either solve the VATS problem (relearning it will likely fix it) or just program the VATS out of it altogether.
Customer: replied 6 months ago.
I had programmed the VATS out, but it still wouldn't start, I disconnected the MAF sensor and was able to get it going with just by requiring the engine to idle at 1000 RPM's. Now the truck won't go into gear. It physically goes into gear, but the dash still shows the unit in park. Got any ideas on that issue?
Expert:  Jerry Newton replied 6 months ago.
It sounds like the range selector circuit isn't hooked up...... although I did a similar swap awhile back and I'm trying to recall this issue..... I think mine was a software issue, did you happen to tune the transmission as a manual trans by any chance?