How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15181
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Chevy 2500 hd silverado: I have a 2011 Chevy truck with duramax.

Customer Question

I have a 2011 Chevy truck with duramax. Just started flashing service stabilitrac and service traction control. Engine has power loss when taking off and transmission will not go into reverse until I shut the engine off then restart it. Any suggestions
Submitted: 8 months ago.
Category: Chevy
Expert:  Daniel Jones replied 8 months ago.
Hello. Welcome to the site. Thanks for coming.I'm ***** *****. I'm here to provide as much information and insight as I can, to best answer your question.You will need to get the system scanned for codes to see what they are. You might need to get the whole system scanned, not just the Engine computer.Can you give me your VIN# ***** I get the proper information for your vehicle? Thank you for posting your question.Your business is very valuable to us.Thank You***** *****
Customer: replied 8 months ago.
Vin # *****
Expert:  Daniel Jones replied 8 months ago.
You will need to get the system scanned for codes to see what they are. You might need to get the whole system scanned, not just the Engine computer.You can check with your local parts stores to see if they offer that service for free. (Autozone or other local chain)Without any codes it will be hard to determine what the problem is.After you get codes it will be a little easier to determine the problem.
Customer: replied 8 months ago.
The fault code showing is UO101 lost communication with transmission control module
Expert:  Daniel Jones replied 8 months ago.
Did you check the ABS system for any codes?
Customer: replied 8 months ago.
The ABS code that's showing is U0101-7F
Expert:  Daniel Jones replied 8 months ago.
What computer did the codes show up in?
Customer: replied 8 months ago.
I'm no expert but I think the first one was inDTC and the other in ABS
Expert:  Daniel Jones replied 8 months ago.
Did you use a code reader to get the codes?If so what Model was it?
Customer: replied 8 months ago.
It's an Innovative 3040
Expert:  Daniel Jones replied 8 months ago.
You will need to check the transmission control module(TCM) to see if you are getting power to it and check the grounds for it. Also the Data line to see if is connecting to the other computers. If you need more help, please use the "Reply" tab to continue our conversation - I'm happy to answer follow-up questions.If you are satisfied with the information I supplied we would like to close out this question.If you have no follow-ups at this time, please remember to Rate My Service.Follow ups are free after ratings, so rate in confidence!Thank you for posting your question.Your business is very valuable to us.Thank You ***** *****