How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jerry Newton Your Own Question
Jerry Newton
Jerry Newton, Chevy Technician
Category: Chevy
Satisfied Customers: 4457
Experience:  ASE Master Technician, L1, Master GM Technician. Over 20 years of bumper to bumper GM experience.
25345654
Type Your Chevy Question Here...
Jerry Newton is online now
A new question is answered every 9 seconds

Have a 2001 1500 4.3 tries to start but then drags. replaced

Customer Question

have a 2001 1500 4.3 tries to start but then drags. replaced starter still doing the same.
Submitted: 11 months ago.
Category: Chevy
Expert:  Jerry Newton replied 11 months ago.

When did this start, did it start acting up after a recent repair or some other incident?

Customer: replied 11 months ago.
after a recent repair
Expert:  Jerry Newton replied 11 months ago.

What was the repair?

Customer: replied 11 months ago.
tune up and replaced crank sencer
Customer: replied 11 months ago.
also replaced starter
Expert:  Jerry Newton replied 11 months ago.

OK, so it was running fine until you replaced the crank sensor and what else, the spark plugs? Cap and rotor? Wires?

Did you replace the starter to repair this condition, or did it start doing this after replacing the starter? Why did you put a crank sensor in it?

Customer: replied 11 months ago.
replacer spak plugs wires ,spark plugs rotor,cap ,starter is rebuilt frome advance auto.started before replacing starter.replaced crank sencer because mech told me it was bad
Expert:  Jerry Newton replied 11 months ago.

What was wrong with the crank sensor, did you have a check engine light on or something like that? If there's an issue with the crank sensor circuit, it will cause this problem.

Also, if you use cheap ignition components, you can have this problem. I only use AC Delco cap/rotor/plugs/wires on 4.3L engines because they are notorious for problems.

Customer: replied 11 months ago.
I used AC DELCO the check engine light was on.dont know the brand of the crank sensor.
Expert:  Jerry Newton replied 11 months ago.

Put the old crank sensor back in, and see if the problem goes away.

Customer: replied 11 months ago.
ok
Expert:  Jerry Newton replied 11 months ago.

.