How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15133
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

2006 avalanche brake pedal squeaking all the

Customer Question

2006 avalanche brake pedal squeaking all the time...depressed and released... engine running or off. Have wd40 it multiple times...no result! It's driving me nuts!!! HELP!!!
Submitted: 8 months ago.
Category: Chevy
Expert:  Jared D replied 8 months ago.

I have squeaks, rattles and chirps when driving. They drive me nuts too!

When your pedal is squeaking does it sound more like a rubber squeak than a metal squeak?

Customer: replied 8 months ago.
Rubber, I think...
Customer: replied 8 months ago.
Hello???
Expert:  Jared D replied 8 months ago.

Sorry, JustAnswer was acting up. It wouldn't let me respond.

Does your avalanche have vacuum assist brakes or hydroboost? The 2007 has both options?

Customer: replied 8 months ago.
I believe vacuum assist
Expert:  Jared D replied 8 months ago.

Do you see a large black donut looking thing between the firewall and the brake fluid reservoir?

The more common option is the hydroboost hydraulic assist and they will sometimes leak fluid internally causing a squeak noise.

This style has fluid hoses running from it to the power steering pulley and is mounted between the firewall and the brake fluid reservoir.

Down at the firewall where the brake pedal rod goes through the firewall pull the carpet back and look for signs of fluid. This is a good indicator that it is leaking through the booster.

Customer: replied 8 months ago.
I don't see a response...if you are having connectivity issues...perhaps we can try again some other time
Expert:  Jared D replied 8 months ago.

I definitely am. I took 4 tries to get that to post. It kept saying an "error occurred".

I don't know if it's the internet here at the shop or JustAnswer's system.

Customer: replied 8 months ago.
ok...no prob...we can try again another day...
bye for now...
Expert:  Jared D replied 8 months ago.

Ok. Let me know which booster it looks like you have when you get a chance and we'll get going again.

Expert:  Jared D replied 8 months ago.

I just wanted to check whether you need any additional help.