How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15133
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Cam we have a 2011 2500 gmc 6.0 savanna van we use it

Customer Question

Cam we have a 2011 2500 gmc 6.0 savanna van we use it for our delivery vehicle .all winter we drove the back up van do to winter, backed this out of the bay everyday then back in everyday a few weeks ago,no start in stead of checking we just put a new fuel pump in and let it go since we smacked the tank and it started. This was 2 weeks ago. Today was the first day out on delivery with this van since nice weather made it to first stop shut it off ,pulled parts out of van went to start back up and it just turned over. Towed back to our shop 35 mins total. set it down off tow truck and fired right up. Well I ran the same route shut off started back up only to find out after it sits for about 10 mins after driving it won't start, turns over, have spark have fuel pressure just as it needs. Let it set for approx. 20 mins it starts right up. We formulated this scenario 5 times today and same result. Pulled colum plastic off checked voltage at ignition checked voltage at injector. 4.6 volts, checked wires at junction same 4.0-6 volts on most everything we checked.
Pulled both connectors off computer checked for corrosion and good. Checked wires on floor area that are known to be damaged at times all good. We are a shop ourself and have good techs. Got us stumped. Just seems like wants it sets possibly it gets hot with out air movement or something happens? All security issues seem to be on and working properly light go out as they should. tried different keys ect. No different. If you squirt either or brake clean in air box it will run and shut down real quick like something is shutting down injector pulse but it does tell us it will start but will not take over after either Evaps. No codes on scanner.we do have rpm so crank sensor should be fine. Has about 200k miles but we put a jasper tranny in it prior to winter it's ran route great since then. What are we missing?
Submitted: 9 months ago.
Category: Chevy
Expert:  Triston replied 9 months ago.

Since you have good mechanics it make it easy for me many things will need to be checked so make it easier and faster please accept a live phone for me when the truck is acting up and you have a voltmeter, test light and a power probe of you have one. But if you rather chat let me know and we'll get started. Thanks