How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15465
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

My car have a problem to maintain idle speed, i got replaced

Customer Question

hi my car have a problem to maintain idle speed ,
JA: Sometimes things that you think will be really complicated end up being easy to fix with a Chevy. The Chevy Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: i got replaced on the car a lot of parts including the following : distributor, tps, air control valve , map sensor , electronic spark control module, egr valve , sparks plugs, spark wires, injector, etc
JA: Are you hoping to fix this yourself?
Customer: yes ill
JA: Great! What have you tried so far?
Customer: this is a 92 chevy astro van seen like dotn mantenience for a long time , i tried all parts changed after tested was wrong or broken . car gos stable after i change couple of the parts i mentioned , but after 3 minutes of idling good dies again and start failing like misfire or rich/lean
JA: Is there anything else the Chevy Mechanic should be aware of about your Chevy?
Customer: dont know
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chevy Mechanic about your situation and then connect you two.
Submitted: 9 months ago.
Category: Chevy
Expert:  Pete replied 9 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Does the exhaust smell like its running rich or lean at all?

Is there any smoke from the exhaust at all?

Let me know so we can continue,thanks Pete.

Customer: replied 9 months ago.
there is no smoke but you can smell like gasoline get it out from the exhaust.
Customer: replied 9 months ago.
it looks like running rich because you smell gas
Expert:  Pete replied 9 months ago.

O.k.,one last thing.If you look at your vin number on the dash through the windshield is the 8th digit a W or a Z?

Customer: replied 9 months ago.
z
Expert:  Pete replied 9 months ago.

O.k.,remove the engine air cleaner and observe the fuel injectors at the top of the throttle body.Turn on the key without cranking over the engine and see if any fuel leaks from them at all and let me know.

Thanks Pete

Customer: replied 9 months ago.
i cant switch to phone call my phone have a broken screen i cant get calls
Customer: replied 9 months ago.
i already did it have new injectors and all of them are good ,
Expert:  Pete replied 9 months ago.

Ok so none leak out fuel with the key on am I correct?

Was the engine computer replaced as well?

Customer: replied 9 months ago.
no i didnt touch the engine computer , i notice like something wrong with current , is not possible to run sometime good and when i shut off and start again the car is totally wrong
Customer: replied 9 months ago.
what do you think can be? i was at ALLDATA telling me a lot of things .
Expert:  Pete replied 9 months ago.

Can you tell me what current was tested that you saw something wrong with it?

Customer: replied 9 months ago.
i didnt test wires, plugs ,or terminals
Expert:  Pete replied 9 months ago.

Were the oxygen sensors replaced at all?

Customer: replied 9 months ago.
i test after read in ALLDATA wires and plugs that goes with ignition and starting actually with emission circuit everything was good , sensor was replaced bet connector was bad i fixed too still the same thing
Customer: replied 9 months ago.
when i turn on the engine the engine check appears on dash engine start failing i go to intake and remove the map sensor tube accelerate and going good but when i palce car on drive engine shut down /
Expert:  Pete replied 9 months ago.

Is this issue only occuring when placed in drive?

Customer: replied 9 months ago.
i was thinking about lack torque converter i never see this before, i got 14 years fixing and repairing cars and this set me like a bad computer on the car .
Customer: replied 9 months ago.
but when i remove the tube of map sensor the car go stable in idle , when i place on drive the tricky thing is car start failing when i accelerate or try to maintain speed .
Expert:  Pete replied 9 months ago.

Is it only occuring in drive though and not when in park and does it rev up in park and neutral o.k. and run o.k. in park or neutral?

Customer: replied 9 months ago.
it occurs in both direcction park and drive, but i remove the tube that connect map with intake and engine light appear and car run stable if i put the tube back car start shaking and failing and engine die. With all components placed engine light is off the car start stable but smell a lot of gasoline .
Expert:  Pete replied 9 months ago.

Can you test the vacuum from this tube with the engine running to see if you have 12 to 15 inches of vacuum and stable not fluctuating?

Customer: replied 9 months ago.
i tested and was stable , i drove the car yesterday for 5 miles making stops and was good after i replace the last thing (the distributor) , i get back palce in park, left running idle for 10 minutes everything was good , i shut off. when i tryed to start again the car was like junk. engine light off smelling gasoline , try to place in reverse engine die , plece in drive engine die too.
Expert:  Pete replied 9 months ago.

This is a tough one for me to answer here myself.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Customer: replied 9 months ago.
thank you sr i appreciiate your help
Expert:  Tim's Auto Repair replied 9 months ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you.

sense the engines light does come on,,,can you give me the trouble codes?

Customer: replied 9 months ago.
I don't have an scanner for that year. This is a 92 .
Customer: replied 9 months ago.
Hi Tim thanks for your assistance I went yesterday to the car making a test on the start switch and looks really old an bad . Do you think this can be the problem? Because first time I start it , was failing I turned off and second time it was without any fail
Expert:  Tim's Auto Repair replied 9 months ago.

i dont think the ignition switch would cause the unstable idle

Customer: replied 9 months ago.
Actually now I don't have the engine light on.
Customer: replied 9 months ago.
But still smelling gas
Expert:  Tim's Auto Repair replied 9 months ago.

ok..i can show you how to scan it without a scanner

Customer: replied 9 months ago.
Ok how is it .
Customer: replied 9 months ago.
Do you think the torque converter or something inside the transmission can make that. Because I notice the transmission fluid was replaced on this. Maybe the torque converter is lacking the engine
Expert:  Tim's Auto Repair replied 9 months ago.

i think you need to remove the egr valve and clean it,,disconnect and plug the vacuum hose to the egr valve,,the egr solenoid may be bad

i dont think it has anything to do with the transmission.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/2wxye39hrla5ie2/0303-s10-ALDL%20Connector.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/2wxye39hrla5ie2/0303-s10-ALDL%20Connector.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

.

Related Chevy Questions