How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George H. Your Own Question
George H.
George H., ASE Certified Technician
Category: Chevy
Satisfied Customers: 18389
Experience:  GM Tech ASE Master Tech 15+ years
13574682
Type Your Chevy Question Here...
George H. is online now
A new question is answered every 9 seconds

2004 NO ACTIVITY SENSOR 2. REPLACED SENSOR TWICE AND NEW CAT

Customer Question

2004 MONTE CARLO NO ACTIVITY SENSOR 2. REPLACED SENSOR TWICE AND NEW CAT STILL NO CHANGE. REUILT MOTOR AND TRANNY AS WELL
JA: Sometimes things that you think will be really complicated end up being easy to fix with a Chevy. The Chevy Mechanic I'm going to connect you with knows all the tricks and shortcuts. Tell me a bit more about what's going on so he can help you best.
Customer: JUST TRYING TO PASS EMISSION. BOUGHT THE AR HAD 3400 MOTOR REBUILT AND TRANNY AS WELL. TOOL IT THROUGH EMISSIO BUT HAD TO GO 50 MILES BEFORE COMPUTER WOULD RESET. HAD P0104 CODE SHOW I REPLACED CAT WITH FLANGE TO FLANGE BOLT ON ALSO REPLACED #2 SENSOER STILL THROWS CODE. SO REPLACED SENSOR AGAIN AND CLEARED AND DROVE STILL COME UP.
JA: Are you hoping to fix this yourself?
Customer: IF POSSIBLE IF NOT I WILL GO TO A SHOP
JA: Is there anything else important you think the Chevy Mechanic should know about your Chevy?
Customer: NO I DONT THINK SO
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Chevy Mechanic about your situation and then connect you two.
Submitted: 9 months ago.
Category: Chevy
Expert:  George H. replied 9 months ago.

Hello I will help you with your question,

Could it be a P0154 not a P0104?

Has the wiring between the sensor connector and the computer been verified as intact?