How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask George H. Your Own Question
George H.
George H., ASE Certified Technician
Category: Chevy
Satisfied Customers: 18561
Experience:  GM Tech ASE Master Tech 15+ years
13574682
Type Your Chevy Question Here...
George H. is online now
A new question is answered every 9 seconds

My name is ***** ***** I have an isssue with my lower brake

Customer Question

hello My name is ***** ***** I have an isssue with my lower brake lights they dont work just the top light work I have a 2006 Chevy silverado
JA: Thanks. Can you give me any more details about your issue?
Customer: my lower rear light won't come on just the bed light (top Light) works when I hit my brake pedal
JA: OK got it. Last thing — Chevy Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Chevy
Customer: replied 1 year ago.
my email***@******.***
Expert:  George H. replied 1 year ago.

hello I will help you with your question,

Can you check at the rear junction block up by the spare and see if you have 12 volts on the light blue wires in the harness coming from the front of the truck with the brake pedal down (third light on)? If you have 12 volts replace that rear junction block and clean any corrosion from the connectors that you find.

Let me know how I can help

Thank you

Customer: replied 1 year ago.
ordered the juction box and I got it on 03/02/2016, cause i did check light blue wire and I'm gettin 12 V but nothing coming out on the pin for the rear brake lights, I installed the juction box and plug all the harness to each connection,but still not light . any suggestion,
thanks
Miguel
Expert:  George H. replied 1 year ago.

Do you see any corrosion on the connectors? Can you check at the bulb sockets to be sure the 12 volts get up to them?

Customer: replied 1 year ago.
Power coming in to junction box, power going out from the junction box, checked light socket no power 0.
Expert:  George H. replied 1 year ago.

Then there must be a break between the box and the lamp connector or the ground that comes back through the box is broken. If you measured both pins at the lamps for light blue and checked it to ground then the break is in the light blue between the box and the lamp connectors but for both to not show 12 volts I would be looking at the connector into the box closely.