How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka-Moose) Your Own Question
Chris (aka-Moose)
Chris (aka-Moose), Technician
Category: Chevy
Satisfied Customers: 44460
Experience:  16 years of experience
2499435
Type Your Chevy Question Here...
Chris (aka-Moose) is online now
A new question is answered every 9 seconds

I have a 07 chevy aveo sedan. Problem is that the engine

Customer Question

Hello i have a 07 chevy aveo sedan. Problem is that the engine cooling fan is not comming on, and temperatuge gauge after like 30 min will pass the haft and continue going up. it is a new fan. i replace thermostat and its the same. Need info on how to check it to fix it, i am getting heat to the inside and both hoses are hot.
Submitted: 10 months ago.
Category: Chevy
Expert:  Chris (aka-Moose) replied 10 months ago.

Welcome, I'm Chris (aka Moose). Experts aren't employees / agents of Just Answer. We are independent service providers using the Site to sell their Expert knowledge to Customers. I strive to provide EXCELLENT 5 STAR service, let me know what's needed from me so your pleased.

Confirm the black wire to the fan OHM tests good to ground.

Confirm both fan fuses are good and have power.

Confirm both fan relays are getting power on pins at each.

At one relay and then the next jump a wire from pin 30 to 87 to confirm you get low speed and high speed fan.

If all have passed that leaves the wiring from the relays to the PCM or the PCM to blame.

Thanks for asking your question and letting me try to help you.

If your confused on why or how to rate me, let me know.

I'm only paid from the deposit you've made when you rate 3,4, or 5 stars.

Follow up/Reply as many times as needed before or after rating.

Customer: replied 10 months ago.
Can u tell me whitch fuses and relats to check? There is no squematic on fuse box. Thanks.
Expert:  Chris (aka-Moose) replied 10 months ago.

https://dl.dropboxusercontent.com/u/90220402/fanrelays.png

Expert:  Chris (aka-Moose) replied 10 months ago.

I like to stay in contact with my customers that appear not pleased, still working on the concern, or have not rated yet. I assume you were not pleased with my help. I hate that you have spent money to get an answer but left not happy. Can you tell me why, or can I help more. If its more help you need just reply and we can pick up where we left off. I am also sending an offer allowing me to upload diagrams or repair guides if that helps.

Thanks Chris