How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15133
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I cleaned the throttle plate and now the engine idles fast.I

Customer Question

I cleaned the throttle plate and now the engine idles fast.I tried unhooking the battery for 15 min.and no good. I have no vacume leaks and now I am lost.2007 Chevy 4.8 V-8 gas
JA: Thanks. Can you give me any more details about your issue?
Customer: The truck has 134k miles on it and I thought it is time to clean the MASS sensor and clean the throttle plate
JA: OK got it. Last thing — Chevy Mechanics generally expect a deposit of about $18 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 10 months ago.
Category: Chevy
Customer: replied 10 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Roy replied 10 months ago.

good afternoon my name is ***** ***** I will assist

how bad was the throttle body??? was it carboned up badly???

Roy

Customer: replied 10 months ago.
NO not bad at all
Expert:  Roy replied 10 months ago.

it sounds like the throttle plate is hanging up and not closing all the way. re check it to verify the plate is closing all the way

Roy

Customer: replied 10 months ago.
the plat closes all the way but as soon as the engine starts it opens up a little
Expert:  Roy replied 10 months ago.

was this an issue prior to cleaning??

Roy

Customer: replied 10 months ago.
No, it ran and idled good.I cleaned it because of the miles on the engine
Expert:  Roy replied 10 months ago.

I would try re cleaning it. it sounds like the plate is not seating properly. if that does not work, you may have to replace the throttle body

Roy

Customer: replied 10 months ago.
Allready tried recleaning it and no good.I do not want to replace the throttle body because it idled ok before
Expert:  Roy replied 10 months ago.

ok, then without me being there, I cannot help you any more. I will open it up to other guys to see what there opinions are at this point

Roy

Customer: replied 10 months ago.
Am I still going to be charged without correcting the problem? Other people on the net have the same problem and they have replaced the throttle body and still have the problem.I have been a mechanic for 45 years and have never had this problem that is why I am trying you.
Expert:  camerontech replied 10 months ago.

hi there

im cam, a licenced diagnostic tech.

dont worry, you dont pay untill you are satisfied and rate us!

did you do a idle relearn on this after cleaning the throttle body?

Expert:  camerontech replied 10 months ago.

any time a throttle body is cleaned and replaced , there should be an idle relearn performed,

this should be done with KOEO, not running.

most people do it with the engine running, than it doesnt work. the engine must be off with key on for it to learn.

i have had to send a few to the dealer just to have the pcm reflashed as the idle learn doesnt always work ffor some reason. but the reflash always works

Customer: replied 10 months ago.
nothing is correcting the problem and I do not want to send it to a dealer because it was fine before I cleaned the throttle plate.I do not know what went wrong because I did not remove any wires and used the correct cleaner for throttle bodies.I have cleaned over 100 when I worked for UPS with no problems. It was a scheduled repair on all gas trucks at work.I am pulling out my hair on this one.All the numbers are OK on the scan tool I use.When I start the engine all is OK until I touch the throttle pedal,some times it will return to the correct idle after 10 seconds and other times it runs 1800 RPMS
Expert:  camerontech replied 10 months ago.

there is a chance the throttle body was damaged during cleaning. it doesnt take much when pushing on the plate that it can throw it off.

they can be damaged while cleaning.

i realize you dont want to take it to the dealer, but it could just require a simple reflash.

i have probably done a thousand of these tb services, and they should all have a relearn with a tech 2 after and some have required a flash after.

the way you describe it, its either binding or the pcm is the issue