How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BOBBYSS Your Own Question
BOBBYSS
BOBBYSS, Master Technician
Category: Chevy
Satisfied Customers: 17142
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH
1627031
Type Your Chevy Question Here...
BOBBYSS is online now
A new question is answered every 9 seconds

I have a 2005 Z71 Suburban it's has four wheel drive there's

Customer Question

I have a 2005 Z71 Suburban it's has four wheel drive there's four button on the dash auto 2w/drive 4w/high 4w/low three of the button work find one button keeps blinking like it will not engage is there a solenoid sensor that might have went bad?
Submitted: 10 months ago.
Category: Chevy
Expert:  BOBBYSS replied 10 months ago.

Hello, my name is Bobby. Thank you for the question. There may be a bad part, a bad connection or the control module is failing. The most common cause is a bad connection. I would start by removing all of the connections on the encoder module on the transfer case. With them removed spray them clean with electrical cleaner. Then apply dielectric grease to the connections and reinstall. If the problem persists then we can move to another are for tests. Please let me know if you need more help.

Customer: replied 10 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  BOBBYSS replied 10 months ago.

Please let me know if you received my previous response and if you have further questions.