How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Chevy
Satisfied Customers: 6878
Experience:  Since 1975
12769047
Type Your Chevy Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

2005 Trailblazer 4.2L Oil Pressure gage pegged, R&R Sensor,

Customer Question

2005 Trailblazer 4.2L Oil Pressure gage pegged, R&R Sensor, fixed problem for two days then pegged again. Disconnected battery ground for 30 sec. normal pressure (40psi) for several days.Where do I look next?
Submitted: 11 months ago.
Category: Chevy
Expert:  rpmdiag replied 11 months ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident we can resolve your problem together. Please understand that I don't know your skill level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in return. I will also continue assisting you after you have rated me, if necessary. If there is any reason I cannot get a positive rating, please let me know why “in advance”, so I can go another direction for you. I am sorry you’re having this problem; I’ll help you through it.

If it's a good sensor, then you either have a bad ground or the gage is defective. You can test the gage with a scan tool too.

Thanks, Ron