How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask BOBBYSS Your Own Question
BOBBYSS
BOBBYSS, Master Technician
Category: Chevy
Satisfied Customers: 17221
Experience:  ASE MASTER CERTIFIED, AA DEGREE AUTO/DIESEL TECH
1627031
Type Your Chevy Question Here...
BOBBYSS is online now
A new question is answered every 9 seconds

I have a 99 chevy s10 blazer (trail blazer) with auto 4wd

Customer Question

I have a 99 chevy s10 blazer (trail blazer) with auto 4wd np236 transfer case when trying to engage 4wd high the light on the switch just flashes it will engage four low when shifting into reverse first then back to drive also auto seems to be working i did get it to engage 4 hi once by shifting to neutral then back to drive then it was hard to get it back into 2wd I have installed a new encoder motor
Submitted: 1 year ago.
Category: Chevy
Expert:  BOBBYSS replied 1 year ago.

Hello, my name is Bobby. Thank you for the question. When you get the flashing light do you get any noise also?

Customer: replied 1 year ago.
I can get the front diff to engage in 4 lo it just seems to be difficult to engage in 4 hi and then back to 2wd I have already checked the module behind the right side kick panel no signs of corrosion there I think it might be in the vacuum solenoid actuator that is located on the firewall above the cap and rotor I was told this is only used on the auto 4wd models by my local napa store and that it is most likely the problem
Expert:  BOBBYSS replied 1 year ago.

That is a common issue, but it may be a transfer case issue. I would start by draining the fluid from the case and inspecting it. This will allow you to check the fluid for metal and other signs of wear. If the fluid is fine then we can run through some electrical diagnostics.

Customer: replied 1 year ago.
ive already changed transfer case fluid and the old fluid had no filings in it and did not look that bad
Expert:  BOBBYSS replied 1 year ago.

Then it is more than likely electrical. Do you have a scan tool to read the codes in this system?

Customer: replied 1 year ago.
I scanned it and no codes were present as current or history and from what I've researched these older models don't usually throw codes like newer model vehicles and yes I know most are vacuum controlled but this is the first one I've owned with auto 4wd I've owned many vacuum controlled s10 and they were easy to work on
Expert:  BOBBYSS replied 1 year ago.

Can you feel the encoder moving when you try shifting the*****

Customer: replied 1 year ago.
i can actually get it to engage its just like the problem is intermittent sometimes it will work as designed and other times the 4 hi will just flash and not engage i tried putting that vacuum solenoid actuator on the firewall on and still does same thing
Expert:  BOBBYSS replied 1 year ago.

Then it is more than likely the transfer case control module keeping it from disengaging. It may be because it is getting a bad input or it is simply failing.

Customer: replied 1 year ago.
can i put a used one in and try it or will that not work ? if not is there a way or trick used to diagnose the tccm cause im sure they are expensive
Expert:  BOBBYSS replied 1 year ago.

It is very hard to diagnose these unless you have a breakout box to do so. You can try a used one as it may work if it is in good shape.