How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Bob Your Own Question
GM Bob
GM Bob, ASE Certified Technician
Category: Chevy
Satisfied Customers: 1060
Experience:  30 plus years. experience as GM technician, ASE Master Technician and GM Certified.
70078276
Type Your Chevy Question Here...
GM Bob is online now
A new question is answered every 9 seconds

I have a problem with car 96 impala SS. Car run minutes then

Customer Question

Hi I have a problem with car 96 impala SS. Car run for 10 minutes then shut off and have no injectors pulse and spark. Sometimes won't start till next day. . I change icm,coil,coolant sensor, what am I missing
Submitted: 1 year ago.
Category: Chevy
Expert:  Eddie replied 1 year ago.

Hello, my name is ***** ***** I will do all I can to help. This may be a tough one to figure out over the internet, but I'm just going to through some things out there to help hopefully narrow it down first. When it doesn't start after running 10 minutes, If you just turn the key to the ON position, and don't try to start it, does the CHECK ENGINE light come on in the dash? Check engine light should come on everytime you turn the key to the ON position. See if you can correlate the light not coming on with it not starting and let me know what you find there.

Customer: replied 1 year ago.
It's always on. I have low resolution on the crank sensor, torque convertor,
Expert:  Eddie replied 1 year ago.

Do you have a scanner that you can see what the crank sensor is doing? if so, are you getting an input from the crank sensor? Also, by chance did the transmission get replaced anytime recently and then this problem start occuring? thanks.

Customer: replied 1 year ago.
I don't have the scanner until 9pm tonight. The tranny was never replace since I own the car 3 years ago. Is the fone call $18 per call or you pay once and all you can call ?
Expert:  Eddie replied 1 year ago.

I'm not sure on the billing end. I'm just a technician here. Have you got a spare key by chance? That vehicle has the ole pass lock GM security system key on it. Does that light go out? and will it crank at all when it doesn't start? I'm thinking Pass lock related.

Customer: replied 1 year ago.
The car crank but no start. No injectors pulse and spark.
Customer: replied 1 year ago.
It's been sitting since 10am this morning. Now she should start right up
Expert:  Eddie replied 1 year ago.

OK, Make sure the check engine light comes ON, and the security light comes on for a couple seconds and goes OUT. Just get in the habit of turning the key ON first, and watch those lights. then attempt to start it. Let me know if the check engine light doesn't come on by chance when it won't start with key ON, and let me know if the security light goes out after a couple of seconds of turning the key to the ON position before starting.

Customer: replied 1 year ago.
Ok she start. I'm gonna let it run till its shut down then I'll look at the check engine light
Customer: replied 1 year ago.
Ok she just shut down again. The security light goes out after a couple of seconds but the check engine light stay on
Expert:  Eddie replied 1 year ago.

go Check engine light should stay on with key on, and security light should go out with key on. all that checks out. You looked at the crank sensor harness well and didn't see any fraying or chafing correct? See if you can see a nice square wave of the crank sensor if you can get a scanner that good. If you can see a square wave from the crank sensor, and still don't have injector pulse, with the security light being out, I'm going to say that the ECM itself could be the culprit. Let me know what you find there.

Customer: replied 1 year ago.
The electronic shop check the harness and said it's ok. My scanner won't see the wave. Where do I go to get another ecm ? Will local auto part have access to one ?
Customer: replied 1 year ago.
Or can I borrow one from the same car to see if its stay running?
Expert:  Eddie replied 1 year ago.

yes you could, at this point if I had an ECM to swap I believe I would try it. make sure it comes out of the same year car (95 and 96 should be same, but double check numbers on the ECM itself). With the Key ON, do you have 12 volts to the injector power wire, should be constant 12 volts to one of the wires going to the injector.

Customer: replied 1 year ago.
I check it with no idea light and I have no flashing. Do I still have to check for 12 volt? So Is the injectors on a negative pulse
Customer: replied 1 year ago.
Noid
Expert:  Eddie replied 1 year ago.

Yes, injectors are on a neg. pulse, one wire will be constantly hot with 12 volts. check it with a regular test light with key ON.

Customer: replied 1 year ago.
I do have 12volt key on.
Customer: replied 1 year ago.
I clear the trouble code and the check engine light stay on cuz I have code po100 mass air flow circuit. Could this be the problem to the engine shut down?
Expert:  Eddie replied 1 year ago.

Its highly possible, unplug it, and leave it unplugged, see if it will start and idle unplugged. If it does, put another one on it. Let me know what happens.

Expert:  Eddie replied 1 year ago.

Hey, any luck with that test? Tell me it's running!

Customer: replied 1 year ago.
Change out a maf sensor but still no
Expert:  Eddie replied 1 year ago.

Do you have a noid light? to plug into the injector harness to see if it has got any injector pulse?

Customer: replied 1 year ago.
tested already. No injectors pulse and spark when it's not running
Expert:  Eddie replied 1 year ago.

Alright, I can only suggest getting a scanner capable of checking that crank sensor input to the ECM, if it had the correct signal to the ECM, I would say the ECM has failed. But, no way to know for sure without those tools, Let me opt out in case another expert has a suggestion. Thank you.

Customer: replied 1 year ago.
My scanner showing too fewer pulse from the crank sensor
Expert:  GM Bob replied 1 year ago.

Hello my name is ***** ***** I can help.

Have you done anything with the distributor that is behind he water pump?

I have a link that has the diagnostic for no spark. The distributor also controls the injectors.

I have had a lot for problems with this distributor causing stalls and running rough.

https://www.dropbox.com/s/lf67ie0e7dolf0z/1996%20Impala%20Distributor.pdf?dl=0

Please let me know if this helps or if you need help with the diagnostic chart

Thank you