How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, Chevrolet Technician
Category: Chevy
Satisfied Customers: 19450
Experience:  ASE Master Certification. GM World Class Certification
11042942
Type Your Chevy Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

I have a 1997 Chevy S10 4WD with a strange electrical

Customer Question

I have a 1997 Chevy S10 4WD with a strange electrical problem. It blows the #3 fuse (20A, parking, instrument lamps) but only when the lights are on and strangely almost always during a right turn! The front axle switch connector seems ok. The truck then runs poorly after it blows. I know there are a lot of things on this circuit and I don't have a good schematic - only a Chilton book. Hoping you may have run into this and can help me through it. Thanks.
Bill Munsch
Milwaukee, WI
Submitted: 1 year ago.
Category: Chevy
Expert:  Dave Nova replied 1 year ago.

Does the truck have any aftermarket accessories (radio, etc.)?

Customer: replied 1 year ago.
No it's all stock
Expert:  Dave Nova replied 1 year ago.

Any trailer wiring?

Customer: replied 1 year ago.
but the connector is cut off and wires isolated and taped off
Expert:  Dave Nova replied 1 year ago.

Double check the trailer wiring, then check wiring going to each taillight and front park lights. You will want to look specifically at the Brown wire at each light. Look for any chafing on this wire or any pinched areas.

Customer: replied 1 year ago.
I removed the trailer "tee" and looked at each harness at the parking lts and they are intact and in good condition. I took it for a ride and at the first rt. turn it blew. What gets me is I can not get the fuse to blow in the garage with it jacked up and wiggling the harnesses every which way. Nor will it blow in the garage by turning the wheel back and forth - only when driving and turning rt. ??? I'm out of fuses and will try again tomorrow. Any other ideas? If it's getting too late just say so.
Expert:  Dave Nova replied 1 year ago.

It has to be a harness that is moving with the vehicle turning or perhaps is getting pinched as the body flexes. Removing the lights and inspecting the harness should be the next step.

Customer: replied 1 year ago.
I think I'm done for tonight. Can I contact you again to try to get this figured out?
Expert:  Dave Nova replied 1 year ago.

Yes, just let me know tomorrow or whenever is most convenient for you.

Related Chevy Questions