How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), Chevy Technician
Category: Chevy
Satisfied Customers: 15201
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your Chevy Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

Im having a problem with a 2008 chevy impala starts and dies

Customer Question

im having a problem with a 2008 chevy impala starts and dies
Submitted: 1 year ago.
Category: Chevy
Customer: replied 1 year ago.
had a prior code for defective oil pressure switch. replaced it. scan for further codes, none. Fuel pressure okay 58psi, spark ok for about 3 seconds and cuts off. visual inspected, okay. fuses underhood and r/h footwell okay. reviewed data, ok. has crank rpm so i ruled out ckp. map sensor readings ok. MAF readings raise as it runs before stalls and looks good. cts normal reading. I was thinking passlock issue but light is not on. I tried the 30 min relearn anyway with no luck. tool i am using is the autel ds708 and looked at bcm for codes, none. theft deterrent mofule no codes too. it recognizes key as valid. but crank, starts for 3 seconds and dies. always. parameters for pcm and bcm looks fine. im stuck and need help thanks
Expert:  camerontech replied 1 year ago.

hi there,

Im cam and ill try to help you in the right direction.

HAve you had a look at the throttle body yet?

These can bind up , since you have a scan tool you can look at the tp voltage 1 and 2.

you can also try a throttle body clean and relearn since you have a scan tool (if it has that feature).

let me know

Customer: replied 1 year ago.
shucks i didnt notice if these are drive by wire. i am not at work yet but will remove duct, clean and visually inspect. also tp voltage
Customer: replied 1 year ago.
but does it sound like a passlock issue with the run and die consistently?
Expert:  camerontech replied 1 year ago.

thats what came to mind at first, but your theft light isnt flashing.

the 30 min "ignition on" relearn doesnt always work either. some of these have a scanner initiated 10 min relearn only and the conventional method doesnt always work.

Customer: replied 1 year ago.
ok thank you. ill inspect tb and get to you!
Expert:  camerontech replied 1 year ago.

awesome.. let me know