How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dave Nova Your Own Question
Dave Nova
Dave Nova, Chevrolet Technician
Category: Chevy
Satisfied Customers: 19451
Experience:  ASE Master Certification. GM World Class Certification
11042942
Type Your Chevy Question Here...
Dave Nova is online now
A new question is answered every 9 seconds

I have a 2007 Chevy Silverado z71 classic body style and the

Customer Question

I have a 2007 Chevy Silverado z71 classic body style and the transmission will not shift out of 1st gear, also the speedometer doesn't work and I have abs and parking brake lights staying on
Submitted: 1 year ago.
Category: Chevy
Customer: replied 1 year ago.
is my email
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Dave Nova replied 1 year ago.

These symptoms are all related. There is no output from the vehicle speed sensor to the computer. This disables abs system, turning on the abs and brake warning lamps. The computer also does not know vehicle speed so the speedometer does not work and the computer does not shift the transmission. Since you said your truck is a Z71, I will assume it is 4wd. This means the speed sensor is located on the transfer case. Check wiring first to make sure all connectors are in place and wiring is not damaged. If it all looks okay, try replacing the speed sensor on the transfer case to see if the speedo starts working. See attached image for location of the sensors. (#3 in picture)

Expert:  Dave Nova replied 1 year ago.

If you have the NP8 transfer case, you will have two sensors. Swap the two around and see if the speedo starts working. If it does then replace the faulty sensor. Sensors are #5 and #4 in the attached picture.

Customer: replied 1 year ago.
It also tells me to service the brake system
Expert:  Dave Nova replied 1 year ago.

This may be tied into the ABS and Brake warnings. Once you have repaired the issue with the speed sensor, check to see if the service brake system warning is still coming on. If it is then the problem is typically in the brake assist pump motor. This is located at the brake booster under the hood. See #3 in attached picture.

Customer: replied 1 year ago.
None of this is even helping me...do you have any other ideas?
Expert:  Dave Nova replied 1 year ago.

What have you attempted to do so far?