How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Chevy
Satisfied Customers: 15706
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Chevy Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

97 Tahoe 5.7 vortec 350 was having random misfires P0300

Customer Question

97 Tahoe 5.7 vortec 350
was having random misfires P0300 codes not sure which exactly. replaced fuel injection spider converted to MPFI. new plugs new wires fresh fuel thoroughly cleaned intake manifold. the problem has gotten a little better but still misses mainly around 2k rpms you can feel it vibrate and hear it in the exhaust. no smoke or smells or leaks. my next guess is EGR valve stuck open or maybe distributor gear going bad. Any ideas?
Submitted: 1 year ago.
Category: Chevy
Expert:  Tim's Auto Repair replied 1 year ago.

Hi, My name is ***** ***** for the delay.

I will do my best to assist you

how much fuel pressure does it have?

is the 300 code the only code you get?

Customer: replied 1 year ago.
it is the only code. I have not checked fuel pressure yet. when you hit the gas a little it runs smooth. mid throttle 1500-3000rpm its choppy. full throttle its smooth.
Customer: replied 1 year ago.
the code called for random missfire
Expert:  Tim's Auto Repair replied 1 year ago.

yes,,the 300 code is a random miss-fire

Expert:  Tim's Auto Repair replied 1 year ago.

it pulls well at wide open throttle?

Customer: replied 1 year ago.
sorry im in a classroom at the moment cannot accept calls. and it feels smooth and sounds normal at WOT but seems like slight loss of power, not by much.
Customer: replied 1 year ago.
its idle is smooth but sounds almost like it has a cam with a mild lope sound
Customer: replied 1 year ago.
also when it misfires the SES light flashes. some more info for you. I had cylinder #6 misfire to begin with. found that the plug wire had been touching the exhaust manifold and was arching off of it. replaced all plugs and wires. could this of caused a short somewhere?
Expert:  Tim's Auto Repair replied 1 year ago.

ok

the first thing you need to do here is to check the fuel pressure,these must have no less than 55psi at all times

Expert:  Tim's Auto Repair replied 1 year ago.

most times when the light fashes like this,it could have a clogged/bad catalyst converter

Expert:  Tim's Auto Repair replied 1 year ago.

stand by,,i will give you more tests/checks for the 300 code

Customer: replied 1 year ago.
I have replaced both cats with highflow flowmasters about 5 months ago so I know its not that. also passed emissions in august. this misfire happened out of nowhere one day, no sign of anything wearing out just a sudden random miss
Expert:  Tim's Auto Repair replied 1 year ago.

ok.

lets test that fuel pressure,,you may have a weak fuel pump[common]

Customer: replied 1 year ago.
I will have my mechanic check fuel pressure tomorrow as I do not have the proper tools for that
Expert:  Tim's Auto Repair replied 1 year ago.

stand by

Expert:  Tim's Auto Repair replied 1 year ago.

PLEASE COPY AND PASTE the link below to your browser, I have uploaded more info on this there please copy and paste the link below to your main browser[INTERNET EXPLORER or FIREFOX]

.

https://www.dropbox.com/s/kbwyxdz7nnyx6zn/1019-tahoe-P0300.doc?dl=0

.

if the link doesn’t work that way, try it this way

thanks

.

www.dropbox.com/s/kbwyxdz7nnyx6zn/1019-tahoe-P0300.doc?dl=0

.

If you are satisfied with my answer, Please Rate my answer by clicking the rating button so I can get credit for my work. I’m not always going to be giving you good news, so please don't let this stand in the way of you accepting my answer. .it does not cost you more money and we will still be able to communicate, ,.please understand, i can not see, hear or touch the vehicle and only know what you tell me. Bonuses and positive feedback are appreciated.. if you are not satisfied with my answer, please do not leave bad feed back ,i will gladly opt out and let another expert handle the question. .if i have sent any diagrams, please print them. .sometimes you may need to right click the image [,then save picture as]to save it to your computer so you can open it with your picture program...Please ask if you need more help

Customer: replied 1 year ago.
things I will check tomorrow will be fuel pressure. distributor cap and rotor, and EGR valve. feel free to throw any ideas out there I will make sure you get your payment after tomorrow. thanks
Expert:  Tim's Auto Repair replied 1 year ago.

please open the link when you get a chance

thanks

Customer: replied 1 year ago.
I read over your link. checking the MAF not a bad idea either. ill keep you posted.
Customer: replied 1 year ago.
also my spark plugs that I pulled out were black and wet so I believe we have a rich issue
Customer: replied 1 year ago.
oh and one more important thing to mention is I got gas in my oil. pulled the dipstick you can smell the gas clear as day
Expert:  Tim's Auto Repair replied 1 year ago.

if it runs rich,you will get another code with the 300,,perhaps a 172

Expert:  Tim's Auto Repair replied 1 year ago.

there is no way to get fuel in the oil...if you do have some,,the intake gaskets are blown

Customer: replied 1 year ago.
okay. do you know if both the upper and lower gaskets could cause this? I did replace the old leaking spider and upper intake gasket
Expert:  Tim's Auto Repair replied 1 year ago.

it is likley the lower[if this is the caase]these do blow from time to time because there is really only four bolts holding it down.2 in front and 2 in the rear

than ks

Customer: replied 1 year ago.
okay. one more quick question sorry. is it possible to remove the lower intake without having to take apart the new spider and upper intake
Expert:  Tim's Auto Repair replied 1 year ago.

not really,,it would be best to remove the upper

Expert:  Tim's Auto Repair replied 1 year ago.

you would break your injectors

Expert:  Tim's Auto Repair replied 1 year ago.

the intakes arent too bad on these..the distibuter is the most aggravating part