How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask JOHN aka Eauto Your Own Question
JOHN aka Eauto
JOHN aka Eauto, The Car Guy
Category: Chevy
Satisfied Customers: 15373
Experience:  ase tech
6149662
Type Your Chevy Question Here...
JOHN aka Eauto is online now
A new question is answered every 9 seconds

I have a 2003 Chevy Impala 3.4 and when I turn the car over

Customer Question

I have a 2003 Chevy Impala 3.4 and when I turn the car over it doesn't start the first time but if I turn the key back off and on again it starts fine?
Submitted: 1 year ago.
Category: Chevy
Expert:  JOHN aka Eauto replied 1 year ago.

its likely a fuel pump that loses prime to verify a fuel pressure gauge is required..

Customer: replied 1 year ago.
Fuel pressure stays constant
Expert:  JOHN aka Eauto replied 1 year ago.

when it cranks and does not start what is fuel pressure...

Customer: replied 1 year ago.
Fuel pressure is at 55psi i try to start it first just turns over turn the key back then try again fires up everytime but not on the first turn
Expert:  JOHN aka Eauto replied 1 year ago.

ok are you checking spark and fuel pressure when the no start occurs? this is important

Customer: replied 1 year ago.
If there's no spark what could be the problem when I first crank it there's definitely fuel pressure to the rails
Expert:  JOHN aka Eauto replied 1 year ago.

no other issues other then the starting issue?

Customer: replied 1 year ago.
No other issues no engine codes car runs fine when running just no start on the first initial try
Expert:  JOHN aka Eauto replied 1 year ago.

do you have a scan tool with live data?

Customer: replied 1 year ago.
Not handy at the moment what should I be looking for
Expert:  JOHN aka Eauto replied 1 year ago.

cam and crank signal... possibly a weak cam or crank sensor

Expert:  JOHN aka Eauto replied 1 year ago.

If you would like any additional information or have more questions please don’t hesitate to ask!

Please remember to only rate my service when you are satisfied. IF you feel the need to rate "Poor Service" or "Bad Service", please stop and reply to me via the REPLY TO EXPERT button with the issue you have. I will be happy to continue further and do everything I can to provide you with the service you seek.

I am not paid unless I get a rating of 3 to 5 Stars/Smiley Faces. If I have helped you with your question, please give me an appropriate rating so that I get credit for helping you

Expert:  JOHN aka Eauto replied 1 year ago.

If you would like any additional information or have more questions please don’t hesitate to ask!

Please remember to only rate my service when you are satisfied. IF you feel the need to rate "Poor Service" or "Bad Service", please stop and reply to me via the REPLY TO EXPERT button with the issue you have. I will be happy to continue further and do everything I can to provide you with the service you seek.

I am not paid unless I get a rating of 3 to 5 Stars/Smiley Faces. If I have helped you with your question, please give me an appropriate rating so that I get credit for helping you